Suppoerter Plugin and Theme Options won't save

Ever since the update to 3.1, I have not been able to save some of the settings within my Supporter Plugin. I am able to update the settings, but am not able to update the plugin’s or the themes options. When I make my selections and click SAVE it re-directs me to the sites home page and does not save the changes. Anyone have any suggestions here? I’m in desperate need to add a few themes to the supporters and I can’t activate them since it won’t save…

Everything is the most current build all the way around.

I’ve tried on three differnt browsers as well to verify it’s not cookies, etc.

Thanks so much.


  • DavidM
    • DEV MAN’s Mascot

    Hi Matt,

    This seems like it could just be a version issue, given the 3.1 update. Could you tell me which version of Supporter you’re working with?

    And as a way to weed out any other possibilities, perhaps you could try reinstalling the latest version 2.2.7 along with the files in mu-plugins and wp-admin?



  • skishopmatt
    • Site Builder, Child of Zeus

    Hi David –

    Again, sorry for the delay there. I’m back. I tried to re-install the plug in and it did not seem to make any difference.

    Some supporter functions work, but changing plug in’s and themes ends up sending me to the main home page.

    Any other suggestions?

    Thank you!

  • Philip John
    • DEV MAN’s Apprentice

    Hiya Matt,

    Sorry for the delay getting back to you with this.

    Can you disable all other plugins and see if you get the same issue? Also try reverting to the default theme as well.

    If that resolves your issue then it’ll be another plugin playing havok. If not, we’ll troubleshoot from there…



Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.