Support Chat issue

Hi,

on Firefox I cannot open a chat-window anymore, although cookies are allowed, check:
http://media.macbay.de/_support/support-wpmudev-support-chat-issue_2102E741.png
This appears as soon as I try to start a support chat.
Pls check and fix, thank you :slight_smile:
Sascha

  • Nahid

    Hey there Sascha ( sushling )!
    Hope you are having a great day!

    I'm sorry to hear about the issue that you encountered. We tried to replicate the issue using the latest version of the Firefox browser in different operating systems and the Live Support Chat worked as expected.

    If you have made sure that cookies are enabled in your browser, could you first try clearing all cache and cookies in it and see if that makes a difference?

    If that doesn't help, could you try disabling all the browser add-ons to make sure none of them are conflicting and causing the issue?

    Hope this helps. We'll be looking forward to hearing back from you. Thanks!

    Kind regards,
    Nahid

  • sushling

    Hi,

    sorry for late reply. I have deactivated al extensions, cleared cache & cookies, restarted FF, logged into my WPMUDEV-account and tried to open a support-chat.

    After clicking on "Send" or "Start" NOTHING happened.
    Then I have re-opened the Support-Chat and this time the chat-window has popped up, but again with this message:

    "Cookies are not enabled in your browser. Please enable cookies before starting a chat."

    This is super annoying after writing a proper bug-report, request or whatever - it completely disappears.

    I'm on latest FF 61.0.1 on Macbook with 10.11 (El Capitan) … I will definitely not switch to Chrome, but to Safari.

    However, FF is actually my preferred browser, only for the reason that they are worth being supported against the other the internet-giants :wink: Too bad that I cannot use it fpr my WPMUDEV account.

    By the way: Login to my WPMUDEV-account using my 1Password-Manager with keyboard-shortcuts is not working and really annoying too, regardless of the browser. I have reported many months ago, any other facing cumbersome usability with password-manager (using keyboard shortcuts) during login?

    Cheers,
    Sascha

  • Nastia

    Hello Sascha

    Hope all is well!

    I've tested our chat with the latest FireFox and El Capitan and could not reproduce this issue. Would you please let us know if the same message shows up in Incognito browser?

    Please make sure the following preferences are selected on your end:
    - In your top toolbar, click on Firefox and select Preferences.
    - Click Privacy & Security.
    - Under History select the options in the dropdown to manage cookies.

    Let us know how it went!

    I've asked from our developers to have a closer look with 1Password-Manager issue. We will follow back once we have an update.

    Kind regards,
    Nastia

  • Baldafrican

    Not to hijack this thread but rather to offer more info and say this happens to me too but on a different browser.

    This is super annoying after writing a proper bug-report, request or whatever - it completely disappears.

    I experience this on Chrome(Version 68.0.3440.106 (Official Build) (64-bit)) where I too type out the whole message and when I click to connect to chat it all disappears and then I have to go through the process again.

  • sushling

    Hello and good day to you all

    First of all I'd like to say "Thank you" for fixing the login-issue I used to have with 1Password!

    The issue with Firefox though is still not solved. I have checked Cookies settings and deleted yours completely, then logged-in again and faced the same issues.

    Then I restarted FF in "safe-mode" (without any addons) and performed the FF-internal-cleaning. Then logged in here again, fired the chat but still received "Cookies are not enabled in your browser. Please enable cookies before starting a chat."

    Any other idea about how to dig deeper for successful troubleshooting?

    Thank you and kind regards,
    Sascha

  • Dimitris

    Hello there Baldafrican,
    in your case, using Chrome, did you also get a message about browser cookies? Or chat window never came up, after pre-chat survey popup? Please advise!

    Dear sushling,
    I'm glad that you can use 1Password without any hustle now! :slight_smile:
    I'm going to perform some more tests on this and contact the lead developer of our site about it, hopefully we will be able to locate something, even though I wasn't able to replicate such state when I tested it in the past (using latest versions of macOS, Firefox and Chrome).

    We'll keep you posted here, as soon as we've got some valuable insights!
    Thank you,
    Dimitris

  • sushling

    Hi,

    after long time I need to request help from your support again.
    So I've just tried to open a support-chat window.

    The same error as reported has occurred again!
    This is really really annoying, because all the text I have provided in the chat-window HAS GONE again.
    Big sigh …

    Again I receive this message in Chat-Modal: "Cookies are not enabled in your browser. Please enable cookies before starting a chat."

    I haven't changed anything in my FF since last time that I've reported this issue to be fixed

    This time I have no time to help you troubleshoot, but I'm willing to provide any logfile export from FF or my Mac so you can dig it …

    Sascha

  • sushling

    Guys, the support-chat is driving me mad, sorry to say so …
    Last time when I have allowed http://livechatinc.com/ to throw their cookies here, the chat has worked fine - until today :slight_frown:

    The same annoying behaviour as before:
    Open Request, type details, start chat … but than the chat-modal opens again with "Cookies are not enabled blah" :disappointed:

    So I checked my browser cookie settings and - again -> http://livechatinc.com/ was not saved.
    This could have resulted from last time when I've reset FF, so it's partly my fault.

    Please please please … Let your chat-modal check first if your users browser allows for these third-party-cookies and not after we have typed in our request, hit "start chat" and loose the issue description typed before. This is causing redundant work, time, nerves …

  • Dimitris

    Hey there sushling

    I'm really sorry for the frustration here! :slight_frown:

    I've already forwarded to our developers this part:

    Please please please … Let your chat-modal check first if your users browser allows for these third-party-cookies and not after we have typed in our request, hit "start chat" and loose the issue description typed before. This is causing redundant work, time, nerves …

    even though I'm not quite sure if this is possible, as the pre-chat survey is happening before any connection made through LC's API.
    I'll keep you posted here, as soon as I've got some valuable insights. :slight_smile:

    Thank you,
    Dimitris

  • sushling

    Hi Dimitris,

    yes, this is consistent. Cannot start the chat from here, having applied all previously named workarounds …

    Mac OSX 10.11 "El Capitan" and FF 63

    I'm communicating with other vendors and service-providers via browser-chat on other sites and never had this kind of problem … I wonder if I'm the only WPMUDEV-user who is facing this issue with FF?

    Please let me know what else I can provide to help you fixing this.

    Thank you and kind regards,
    Sascha

  • Dimitris

    Hello there sushling,

    I'm really sorry to hear that! :slight_frown:

    I gave this another try using OSX 10.14 & FF 63.0.1 and worked well without any issue.
    This is really a browser-side issue, allowing LC cookies should be enough to get you going... did you double check that you still have their domain in your allowed list? Sorry for asking the same thing as before, I really can't think of anything else at the moment... please advise! :slight_smile:

    Warm regards,
    Dimitris

  • sushling

    It started to work again, after forcing FF to allow those cookies permamanetly … Too bad you have to use a third-party-SaaS for this :wink:

    Today I made another - not so positive - experience: An agent has posted a link to your docs in chat, I have opened the link in 2nd tab, where the chat-window appeared as a dubplicate chat-window, so I had it open in two windows, then I closed one the previous tab, because the bell was always chiming double which is pretty disturbing, but then the chat has completely closed when closing the first tab …

    Guys, sorry to say, but I'm experiencing ongoing problems with your support-chat-system … I'd like to stop using it and wish so much that you would offer to use your chat on a dedicated window or tab, but not integrated with your site anymore. Even better: Please provide Support via Slack!!!

    Kind regards,
    Sascha

  • Dimitris

    Hello there sushling

    Today I made another - not so positive - experience: An agent has posted a link to your docs in chat, I have opened the link in 2nd tab, where the chat-window appeared as a dubplicate chat-window, so I had it open in two windows, then I closed one the previous tab, because the bell was always chiming double which is pretty disturbing, but then the chat has completely closed when closing the first tab …

    Really appreciate the sharing on this, I was able to replicate the same behaviour using Firefox, while Chrome is still working good.
    I've already created a report for our developers, so they can have another look at that.
    We'll keep you posted here, as soon as there's any development on this.
    Thank you once again! :slight_smile:

    Guys, sorry to say, but I'm experiencing ongoing problems with your support-chat-system … I'd like to stop using it and wish so much that you would offer to use your chat on a dedicated window or tab, but not integrated with your site anymore. Even better: Please provide Support via Slack!!!

    Appreciate the thoughts on this, I've forwarded them to our growth team already.
    As for Slack, it still misses some basic functionality that we're requiring to perform better as a team. :slight_smile:

    Thank you,
    Dimitris

  • Dimitris

    Hello there sushling

    Today I made another - not so positive - experience: An agent has posted a link to your docs in chat, I have opened the link in 2nd tab, where the chat-window appeared as a dubplicate chat-window, so I had it open in two windows, then I closed one the previous tab, because the bell was always chiming double which is pretty disturbing, but then the chat has completely closed when closing the first tab …

    Really appreciate the sharing on this, I was able to replicate the same behaviour using Firefox, while Chrome is still working good.
    I've already created a report for our developers, so they can have another look at that.
    We'll keep you posted here, as soon as there's any development on this.
    Thank you once again! :slight_smile:

    Guys, sorry to say, but I'm experiencing ongoing problems with your support-chat-system … I'd like to stop using it and wish so much that you would offer to use your chat on a dedicated window or tab, but not integrated with your site anymore. Even better: Please provide Support via Slack!!!

    Appreciate the thoughts on this, I've forwarded them to our growth team already.
    As for Slack, it still misses some basic functionality that we're requiring to perform better as a team. :slight_smile:

    Thank you,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.