Support Plugin

I receive an error involving PHP 5.2 or better. I'm using PHP 5.3. Why am I receiving this message? Its bothersome to pay so much and get such issues...