Support Ticket Management System Not Sending Email

Hello,

The Support Ticket Management System plugin isn't sending email to notify me (the super admin) or the user who submitted the ticket. Other emails send, like forgot password, new user, etc from my system, but I don't seem to be getting emails from the support system - no emails in spam either.

Am I missing a configuration option or do you know what I should look into to get the emails working?

Thank you!

  • TJ

    When I look at the last few lines of the mail log file this is what I see:

    May 31 17:47:35 localhost postfix/smtp[14156]: B25F7510628C: to=<TJ@NevisTechnology.com>, relay=aspmx.l.google.com[74.125.29.26]:25, delay=0.45, delays=0.1/0/0.24/0.11, dsn=2.0.0, status=sent (250 2.0.0 OK 1464731255 l61si20790355qtd.106 - gsmtp)
    May 31 17:47:35 localhost postfix/qmgr[5347]: B25F7510628C: removed
    May 31 17:48:46 localhost postfix/smtpd[14152]: connect from localhost.localdomain[127.0.0.1]
    May 31 17:48:46 localhost postfix/smtpd[14152]: 49812510628E: client=localhost.localdomain[127.0.0.1]
    May 31 17:48:46 localhost postfix/cleanup[14155]: 49812510628E: message-id=<c3fc8a02c4c1be01e033d17535b7c09a@nevtecems.com>
    May 31 17:48:46 localhost opendkim[4074]: 49812510628E: DKIM-Signature field added (s=mail, d=nevtecems.com)
    May 31 17:48:46 localhost postfix/qmgr[5347]: 49812510628E: from=<support@nevtecems.com>, size=2353, nrcpt=1 (queue active)
    May 31 17:48:46 localhost postfix/smtpd[14152]: disconnect from localhost.localdomain[127.0.0.1]
    May 31 17:48:46 localhost postfix/smtp[14156]: 49812510628E: to=<TJ@NevisTechnology.com>, relay=aspmx.l.google.com[209.85.232.26]:25, delay=0.43, delays=0.09/0/0.2/0.14, dsn=2.0.0, status=sent (250 2.0.0 OK 1464731326 143si32449161qhx.131 - gsmtp)
    May 31 17:48:46 localhost postfix/qmgr[5347]: 49812510628E: removed

    It seems like it sends 2 emails? And successfully? I don't see them, even in the spam folder. So I tried changing the TO email address by changing the email under Support > Settings, but it still tries to send it to TJ@NevisTechnology.com.

    Is there another place to change where the email gets sent?

    I am thinking there is some kind of block with my email provider for that account - I'm not getting forgot password emails there either.

    I can't seem to find where the reference to this email address is coming from now that I changed it, though. All of my multisites have my email address (I'm demoing functionality right now), including the super admin, the main site, and now Support > Settings. So I'm not sure where else to change it...where is the support plugin finding the email address to send to?

  • Ivan Shulev

    Hey TJ ,

    I hope you are having a nice day so far!

    I would need to do testing on site and for that I will ask you for FTP credentials.

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic.

    Send in:

    Subject: "Attn: Ivan Shulev"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Thank you and I wish you an awesome day ahead!

    Ivan

  • TJ

    Hello Ivan,

    I may have figured this out. I think it was the server's SMTP server was getting flagged or something by email providers...so the email wasn't getting to the inbox or it was going into the spam folder. I updated postfix to send through Zoho and now Amazon SES and I haven't had any issues.

    Is it possible these days to set up a local SMTP server and have the emails get to their location properly? Or do you pretty much have to use a 3rd party SMTP server?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.