Supporter 2.0.5 failing

I just upgraded to Supporter 2.2.5 from 2.2.4. Couple of things:

the WPMUDEV plugin in area still shows that I have 2.2.4 installed.
When I click on Supporter (PRO) under SuperAdmin I get the default work area with graphs.

When I click on Modify a Blog it goes to:
http://minblogs.com/wp-admin/settings.php?page=supporter&tab=manage
which displays a page from the blog's front end, and in the browser tab is says "Nothing Found for http://minblogs.com/wp-admin/settings.php?page=supporter&tab=manage"

It fails the same way for Settings, Premium plugins, and Premium themes. Help.

thanks, Ted

  • kingdomtools
    • Design Lord, Child of Thor

    OK, I see from this thread:
    https://premium.wpmudev.org/forums/topic/unable-to-access-supporter-admin-pages

    Supporter 2.2.5 is not 3.0.4 compliant, and we are to roll-back (WP or Supporter, not sure. WIll try Supporter first since you don't specify).

    I am VERY disappointed that there is no warning from WPMUDEV on this. In fact, the only reason I upgraded was because I got sick of staring at the pink warnings to upgrade. You even state on the Supporter plugin page that it is compatible with 3.0.4 - you are not living up to your guarantee for plugins that "work".

    My trust in WPMUDEV is beginning to wain. I have to manually install all the plugins, discover the bugs myself, and common sense stuff like "Supporter" and "Upgrades" conflict, or in the very least don't work as simply as you would have us believe pre-subscription.

    I have yet to catch a dev on your chats. Forum support is slow (for a paid solution). Although a lot of your stuff works, and is appreciated. But I am going to have to seriously rethink renewing our subscription and can't seriously reference you to my friends at this time.

  • drmike
    • DEV MAN’s Mascot

    Can you confirm what version of wp/wpmu/ms you;re using please? We're getting to the point with the pending 3.1 changeover we need to make sure we're including versions numbers again as we've already had folks using the 3.1RC and that's caused issues.

    And a check of your webserver's error logs please.

    edit: The changelog says the 2.2.5 version is for wp v3.1. That's probably the issue.

    reedit: We caught each other in postings up there. Sorry about that.

  • kingdomtools
    • Design Lord, Child of Thor

    WP 3.0.4 (multisite)
    BP 1.2.7

    edit-
    understood. But I still have a 3.0.4 WP site that it's not working with.

    Information:Version: 2.2.5
    Other Versions »
    Compatible With:
    WordPress Multisite 3.0.4 and BuddyPress 1.2.7

    Your help is appreciated.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.