Supporter 2.2.2 install and language files

Hi,

Just installed Supporter 2.2.2 and have two questions:

1) Install instructions seems to be outdated. I have to try different file locations in order to get the plugin activated (e.g. mu-plugins is deprecated). Due to this I am not certain the proper files are on the proper folders. I would like it very much to review the whole installation.
Are there any updated install documentation?

2) There is no pot on language folder. Also there is no po file on the installation package.
Are there any pot/po files available to this plugin?

Regards,