Supporter doesn't support UTF-8 unicode?

Hello, I have installed supporter and translated some sentences and phrases from settings page in Georgian (which needs utf-8 unicode).

I am surprised that this plug-in doesn't support UTF-8. I need it very much, please help me somehow.. :slight_frown: