Supporter + Domain mapping Option Not Available???

Hi, WPMUDEV team,

I tried my best to avoid asking any unnecessary questions, but now i am stumped. Well i have 2 questions:

1: Where i is the option to allow domain mapping as a supporter upgrade? I Have domain mapping Version 0.5.4.1 and supporter Version 2.2.8.

Screenshot of the option here: https://premium.wpmudev.org/wp-content/uploads/2010/09/domainmapping.jpg

I am on hosgator shared business plan which comes with a free dedicated ip and ssl. After following the installation instruction for DM plugin i checked my ip address in FF browser and it leads me to hosgator 404 error page.

So my question is how to fix this ip issue?

Thanks

Follow up Q: My main blog domain is mydomain.com i purchased mydomain.net for mapping purposes, but when i go to the .net it still takes me to the sub.domain.com even though the address is mydomain.net and i pointed the .net to the .com root folder.

So is that normal? should the .net take me to the .com and the other way around?

  • DavidM
    • DEV MAN’s Mascot

    Hi Jahsun and welcome to WPMU DEV!

    For your initial query, the options should be in at Network Admin -> Settings, toward the bottom of the page there.

    A dedicated IP is optimal for using Domain Mapping and the IP shouldn't lead to a 404 after activating Domain Mapping. If you deactivate Domain Mapping does the IP still 404?

    Regarding your final query, the .net should route to .com if you set it up as such. Have you checked your domain name settings in your cPanel?

    Cheers,
    David

  • Jahsun
    • New Recruit

    Hey thanks for the warm welcome DavidM.

    Well i checked and double checked, there is no option at all for DM as supporter upgrade. Take a looking at the screenshot: Network admin>>>network settings.

    I deactivate DM plugin, but ip still gives 404 error. I am going to check all settings for ip hopefully something will popup to resolve everything.

    Thanks again

  • Jahsun
    • New Recruit

    I also checked the site admin settings and nothing, no option for domain mapping as a supporter upgrade.

    As far as the other issues i have my hosting company looking over things it maybe an issue on their part. The only thing is that my dedicated ip can only point to my main hosting domain (according to hostgator) which not the domain my wordpress main blog is installed on. I still cannot figure out why this option is not available to me.

    I am still seeking assistance
    Thanks in advance

  • DavidM
    • DEV MAN’s Mascot

    Hi Jahsun,

    In your screenshots, I don't see the Domain Mapping options at all. I'm wondering if it's installed properly? Can you check to be sure it's installed in wp-content/mu-plugins/ as mentioned in the following?
    https://premium.wpmudev.org/project/domain-mapping/installation/

    As for the IP yielding a 404, I don't believe there's a way Domain Mapping could do that, however Multisite itself handles things there and this could have to do with Multisite.

    There's a bit of discussion on this at the following in case it helps.
    https://premium.wpmudev.org/forums/topic/domain-mapping-ip-address

    Cheers,
    David

  • Jahsun
    • New Recruit

    I double checked. sunrise.php is in wp-content. domain_mapping.php is in wp-content/mu-plugins.
    define( 'SUNRISE', 'on' ); in in wp-config (check screenshot).

    For the IP issue yeah it's my host they are trying to resolve this. The .net not pointing to the .com it's also hostgator.

    Have anyone used hostgator shared hosting and accomplish setting up domain mapping correctly with the option to select domain mapping as a paid supporter upgrade?

    Thanks again DavidM

  • James Farmer
    • CEO (of WPMU DEV, honest)

    Hi Jahsun,

    Just checking if it was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, could you let us know by re-opening this topic, and we'll get onto it and helping you out asap!

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Cheers, James

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.