Supporter - "The plugin does not have a valid header."

Getting an error when installing Supporter plugin. Go to activate and WordPressMU says "The plugin does not have a valid header." When I look at the install instructions, all pages are in appropriate folders, db table has been created, don't understand what I am doing wrong.

Should I not be installing via zip file upload and transferring via ftp? Or does that matter?