Sync Error

after Sync i get the this error from the Subsite - You do not have sufficient permissions to access this page. What have i done wrong. I feel my admin details changes from the master to the subsite.

what do i do please.

  • aecnu

    Greetings amyandrew,

    Welcome to WPMU Dev!

    Have you followed the instruction to include placing the generated key from the Master into the Slave?

    Earlier today I had a member whom gave the exact same symptoms that you have and in the end they found it was there severs security system preventing this from working though they did not mention what they did to fix it.

    Probably something to do with a block on cross domain scripting or mod_security enabled.

    Could you please ask your host of they are using either of these security measures and advise me so I can hopefully offer a solution?

    Cheers, Joe

  • amyandrew

    The two sites am actually trying to sync is a main WP site (Master) and Sub domain (slave) which is a Buddypress.

    I have over 10,000 users on my wp site and want to migrate these ones to my Buddypress site..The whole connection is ok as i have inserted the Master Key and Domain on the slave site and everything is fine.
    Last time it transfered about 3,400 users and automatically logged out. And gives me the above error, when i try to enter the wp-admin of the Slave site. "You do not have sufficient permissions to access this page".

    My wordpress version isWordPress 3.2.1.

    Buddypress Version is Running on a WordPress 3.3.1.

    And BPress 1.6.

    My Host couldnt give me information with regard the Mod_security been enabled or not.

    Thanks

  • aecnu

    Greetings amyandrew,

    Thank you for the additional information, it is appreciated and greatly helps our effort to figure out what is going on there.

    One of the first things that has caught my eye is the difference in WordPress versions, this is something you want to address in the near future but I do not believe is causing this error.

    It is obvious your host is not being very cooperative and then should know 100% if the sever is running mod_security - but from the additional information you gave me this is not the issue either because you did manage to transfer a portion of the users - mod_security if it were causing a problem would not even allowed one user to be transferred.

    It is my opinion from the information gathered that the real issue here is a php timeout.

    Inside the servers php.ini file is a specified amount of time that a php script may run, and from the very symptom that you have that part way through it stops is a direct symptom this could cause - by halting the script before it has finished its run.

    Could you please check your hosting error logs to see if there are any entries to confirm my suspicions or possibly shed some direction to further dig into this anomaly.

    Please advise.

    Cheers, Joe

  • aecnu

    Greetings amyandrew,

    You are most certainly welcome and thank you for being a WPMU Dev member!

    This should help a lot - though we may find that sixty seconds is not quite long enough but we will not know for sure until we run the script and look at the numbers.

    For example, lets say that we make it now to 8,000 users synched then we know we are on the right track but need more time.

    On the other hand I hope to see that we make it all the way to 10,000+

    Please keep me appraised of the situation.

    Cheers, Joe

  • aecnu

    Greetings amyandrew,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted

    Thank you for being a WPMU Dev member!

    Cheers, Joe