Tables are not appearing on Marketpress product page

Hi,

I am currently setting up some products with Marketpress, and in the product description, I have a table.

This table does not appear on the product page. When I copy and paste the table code into a regular post, it appears just fine.

Any thoughts? Is Marketpress blocking this somehow?

  • PC
    • WPMU DEV Initiate

    Hello @gnomecircle

    Greetings and thanks for posting on the forums.

    How are you adding the tables ?

    I just tested it and added the table code in the text editor while creating a product and it works fine.

    You can see it live here : http://marketpress.wpdemo.in/store/products/testing-table/

    Here is the code I added

    <table border="1">
    <tbody>
    <tr>
    <th>Header 1</th>
    <th>Header 2</th>
    </tr>
    <tr>
    <td>row 1, cell 1</td>
    <td>row 1, cell 2</td>
    </tr>
    <tr>
    <td>row 2, cell 1</td>
    <td>row 2, cell 2</td>
    </tr>
    </tbody>
    </table>

    Can you please let me know the code you are using so that I can test and suggest accordingly ?

    Please advise.

    Cheers
    PC
    Sales &Support

  • gnomecircle
    • Flash Drive

    Not happy that you got that to work so easily. :slight_smile: So I tested it out as well, by creating a second product and adding the table there... it worked fine.

    I went back to the problematic product and changed the only other variable. (I had listed 6 different variations of the product. These were not appearing either, nor were the buy button, or any kind of price.)

    Once I remove the variations, the table appears as well as price and buy button.

    I don't really need the variations, so I guess this is resolved, although it is curious.

    Thanks!

  • gnomecircle
    • Flash Drive

    The only bit of code in the post is a <ul> nothing else. As for the CSS, I have not even looked at it yet. It's an out of the box Genesis Framework, but the same was happening with the twenty-ten theme. Weird. The only other variable I can think of is that I am running this locally (MAMP,) but that couldn't be it.

    I will continue to test this as the site takes shape. I will report back what I come up with.

    Thanks,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.