Tag and Category Pages Not Displaying Wikis

Hi, this is loosely related to my previous question (https://premium.wpmudev.org/forums/topic/removing-sidebars-in-wiki-incsub_wikiphp-to-achieve-full-width)

When I click on the link to view the Category or Tag beneath the wiki entry, I am taken to a page that is typically used for "Portfolio" items in my theme, Cold:

http://e404themes.com/cold/

I'm pretty sure "Portfolio" is a Custom Post Type added by the theme.

To test this behavior for yourself, you'll need a login:

https://members.learnvisualstudio.net/

[removed for security]

(I'll be removing that login after this thread is expired).

http://members.learnvisualstudio.net/wiki/one/

This page uses a heavily modified index.php that apparently is used for the list of blog items and individual blog items. Clicking on the "FirstTheme" and "FirstTag" will yield the undesired result ... a page that says "Nothing found."

The theme has a "theme options" page where you select a Page (not a Post). I created the Page, and selected one of the theme templates for the Portfolio Custom Post Type; one column w/ sidebar.

I'm confused how the Wiki plugin knows about the Portfolio Custom Post Type. More importantly, what do I need to do to make sure that my theme can accommodate the Category and Tag lists?

    Tyler Postle

    Hey Bob,

    I tried the login credentials you placed in the question; however, they didn't work - I also removed them just in-case anyway.

    Would you mind granting support access through your WPMU DEV Dashboard in admin? That will be a more secure way of doing it

    You can navigate through WPMU DEV > Support > Support Access > Grant Access.

    Let me know when you have done that, then I can take a closer look.

    I'm confused how the Wiki plugin knows about the Portfolio Custom Post Type.

    Plugins will be able to see which custom post types you have in your theme, if needed anyway

    Look forward to hearing back on this Bob.

    Talk to you soon,
    Tyler