Taking too long to ungroup

It is taking way too long to ungroup on Upfron Builder: https://www.youtube.com/watch?v=VLDFO_OtSJQ
Since I have tested many many drag and drop tools with no delay, I do not think it fair to say it is my server`s lack of memory. Thank you.

  • Adam Czajczyk

    Hello diegpl,

    I hope you're well today and thank you for your question.

    There's over 100 plugins installed on the site (while I can see that 14 of them is network enabled, I don't see which of them are active on particular sites) and there's 155 sub-sites. The 256M of PHP memory available may be enough to handle that but only 64M is granted to WordPress currently and it's a little and may be causing some serious performance issues.

    That's a side-note though. I'm not saying that definitely that this is the reason for "slow un-grouping" but I would strongly suggest starting with raising the amount of memory allowed to be used by WordPress to the amount of PHP memory (256M). You may do this by adding this line to the "wp-config.php" file:

    define('WP_MEMORY_LIMIT', '256M');

    That line should be located above the "/* That's all, stop editiong... */" line and "WP_MEMORY_LIMIT" shouldn't be confused with "WP_MAX_MEMORY_LIMIT".

    That being said, I do not say that this is definitely a reason for the issue. If it was my site though, I would start with this and if that doesn't change anything, I would dig deeper. Can you please make that change? If it doesn't help, let me know on which sub-site of your site I can proceed with tests (I understand it's a live site so I wouldn't want to break anything important during testing). I will then check it and look what may be slowing it down.

    Kind regards,
    Adam

  • diegpl

    Some people here told me to set my server up with this on php.ini:
    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 300
    Other ones told me to set php_value max_execution_time 180 on htaccess and now you are telling me to set memory limit to 256M. Which settings do you suggest me to take?
    Although I have some plugins network activated they are not taking to much memory though. They are just a pro-sites and "new blog templates" environment. And I already tested other drag and drop plugins and themes on my network without any problem. Increasing my server memory I may solve the problem, but it seems that Upfront Builder is also taking much memory as well. Thank you!

  • Predrag Dubajic

    Hi diegpl,

    Recommended setting depends on your site setup and what you have running there, we usually recommend increasing the value depending on the one you have already, if you're running on 64MB as Adam said then it's suggested to start with increase to 128MB but since you have quite a few plugins it might be best jumping straight to 256MB.

    If we see errors on your site that say that 256MB are also exhausted we may suggest using 512MB instead.
    I'm not sure who suggested you to use 512MB but they probably had a reason of doing so.

    I've tested your site and ungrouping takes only a second or two now as you can see here https://screencast.com/t/J2ya4uadZ so you should be good with keeping 256 limit for now.

    Best regards,
    Predrag