Taxonomy not editable

First -- congrats on the new plugin. I love it so far.

But -- I've tried adding a custom taxonomy and attaching it to the custom post type and both of them say You cannot modify this taxonomy.

Other than change the labels a bit I've not changed any of the defaults.

Anything I could have done wrong?

  • Mason
    • DEV MAN’s Sidekick

    Hiya cbesett,

    Thanks for your kind words about the plugin. We're glad to hear you're enjoying it.

    Can you tell me a bit more about where this message is appearing? Is it on the Taxonomy tab? When you click a 'edit' on a specific taxonomy?

    I've edited taxonomies and even edited which post types they are connected to after adding content and haven't seen this issue come up. If you can tell us a bit more about where it's happening, we'll take a look with ya.

    Thanks!

  • Mason
    • DEV MAN’s Sidekick

    Hiya guys,

    Trying to reproduce this problem. Can you tell me what the user role is when you're seeing this?

    @cvgrubbs thanks for the screenshot. Is that of a custom post type created with this plugin? You shouldn't see the default 'categories' and 'tags' meta boxes when using this plugin (unless you custom created them)

    Also, has anybody made any changes to the Capability Type or any other of the 'Advanced' settings on the Post Types page? I'm just not able to reproduce this error. I'll ask Ivan to comment further on this one.

    Thanks for your continued feedback!

  • Ivan
    • The Incredible Code Injector

    @cbesett, @cvgrubbs, @deeply Hi there guys,

    Thank you for reporting this, this is related to the user capabilities. The current user don't have the necessary capabilities for editing the taxonomies. Admin users have rights to edit terms by default. Can you provide more info about this. Do you get this when logged in as admin or you get this if you use another user role ( editor, author etc... ) ?

  • cvgrubbs
    • WPMU DEV Initiate

    I was testing the plugin on a WP site that did not have the network setup yet. I thought it would still work. As the Admin, the screen shot is what I saw.

    After reading what Ivan said, I set it up for multi-site and as the SuperAdmin, seems to be working fine.

    I'll post again tomorrow to confirm.

  • Ivan
    • The Incredible Code Injector

    @thegamenet Can you provide more info about your setup, e.g. are you running SS(Single Site) or MS(Multi Site) ? Do you have the plugin Network activated if on MS ?

    @cvgrubbs

    The box for Page Attributes selection still does not show up..

    Kudos for you, this is a bug :slight_smile:. This will be resolved in the next release but if you want to fix it for your current setup do the following:

    Open "cp-submodules/content-types/ct-admin-ui" directory and edit the following files:

    ct-admin-ui-add-post-type.php : On Line 71 edit the value of the page attributes check-box from "page_attributes" to "page-attributes" ( dash replaces the underscore ). Do the same for ct-admin-ui-edit-post-type.php on Line 74.

  • George Vanous
    • New Recruit

    I'm having this for 'category' style Taxonomies. I'm setting-up a database with 2-Fields of repeatable, but also growing data. Hierarchy is very important, so I've got the 2 category-boxes on my custom-post-type, however I can 'add new X', just not select/unselect existing ones. Have tried both with New and Edit.

    Thank you

  • Ivan
    • The Incredible Code Injector

    @cvgrubbs

    I've made the changes to those files, now the box shows up but does not allow me to select a template.

    Going to "quick edit" on one of my custompress posts, the select template box is there. But, when I select a template, it does not save it. It just goes back to default after clicking "update".

    Unfortunately WordPress currently supports the Template feature for only the "page" post type. Here is simmilar thread on wordpress.org - http://wordpress.org/support/topic/register-post-type-attributes Also check the http://codex.wordpress.org/Template_Hierarchy documentation. It will give you in depth understanding of the WordPress templates.

    @thegamenet

    I'm having this for 'category' style Taxonomies. I'm setting-up a database with 2-Fields of repeatable, but also growing data. Hierarchy is very important, so I've got the 2 category-boxes on my custom-post-type, however I can 'add new X', just not select/unselect existing ones. Have tried both with New and Edit.

    Yes, I am 100% sure that this is a bug with the user capabilities. You will have to provide more info about your setup so I can recreate the bug and give you the solution. Please share your PHP version, WordPress version ( SS/MS ). Also the user role with which you are expiriencing this ( Super Admin if on MS ? / Admin on MS but not on the root ? / Admin on SS ? ... etc ).

  • mycroft
    • Flash Drive

    I am having the same issue. Fresh WP 3.0.2 install, newest version of the plugin, as the admin user.

    php -v:
    PHP 5.2.9 with Suhosin-Patch 0.9.7 (cli) (built: Apr 26 2009 16:28:47)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

    uname -a:
    FreeBSD server2.xxxxxxx.xxx 7.1-RELEASE FreeBSD 7.1-RELEASE #0: Thu Jan 1 08:58:24 UTC 2009 root@driscoll.cse.buffalo.edu:disappointed:usr/obj/usr/src/sys/GENERIC amd64

  • alberti
    • Site Builder, Child of Zeus

    I'm having a similar problem to cvgrubbs original post. The user named emerson has administrator privileges, but can't check existing boxes in the custom taxonomy:

    Only the person logged in as "admin" can check or uncheck the above boxes, even though emerson is logged in. The only way I could check them in the first place was to have user "admin" check them. I'm not sure what else to do with user permissions, if this is a bug, or a limitation (which wouldn't make sense). Please advise.

  • Ivan
    • The Incredible Code Injector

    Try the following solution for the capabilities bug:

    Add the following function to the end of "cp-core.php":

    function cp_roles() {
    global $wp_roles;
    if ( $wp_roles ) {
    $wp_roles->add_cap( 'administrator', 'manage_terms' );
    $wp_roles->add_cap( 'administrator', 'manage_categories' );
    $wp_roles->add_cap( 'administrator', 'edit_terms' );
    $wp_roles->add_cap( 'administrator', 'delete_terms' );
    $wp_roles->add_cap( 'administrator', 'assign_terms' );
    }
    }
    add_action( 'init', 'cp_roles', 20 );

  • afino
    • Flash Drive

    Guys, having the same problem here. I'm running Multisite 3.0.1. Anyone with SuperAdmin rights is fine but all other users get the Taxonomy error. I really appreciate a fix asap - thanks!

    It's a fantastic plugin btw and fixing the privileges bug will just make my week as my users are chomping at the bit to use it.

    Cheers,
    Fiona

  • CPS
    • WPMU DEV Initiate

    I am using Single-Site, and am logged in as the Administrator, and cannot check off the taxonomy boxes in my post. This is a pretty huge problem, as I need to be able to categorize posts for the site search.

    If you could please advise on a proper fix, or the date for the next update, it would help greatly as I cannot complete a client's website until this works. This plugin promises amazing things, so I can't wait to get it working! I tried your live chat, but no one seems to be there to answer our questions. *sadface*

    Thanks!

  • Mason
    • DEV MAN’s Sidekick

    @fiona & @CPS did you try Ivan's solution above? He's doing some final testing bits and we'll have an update out as soon as possible. If you guys could test this out it would greatly help us make sure we've found a solid solution.

    Thanks!

  • CPS
    • WPMU DEV Initiate

    @MasonJames

    I have tried out that solution, and nothing changed with the plugin. I have the taxonomy set to hierarchy, and I have generated two sample categories underneath the taxonomy that should be clickable. I honestly have no idea what to do. It's so close to working that I can feel it!

  • afino
    • Flash Drive

    Hi, I tried out Ivan's solution but it didn't work for me unfortunately. FYI I also have the taxonomy set to hierarchical same as CPS in case that's relevant.

    Let me know if you need me to test out any other possible fixes.

    cheers,
    Fiona

  • CPS
    • WPMU DEV Initiate

    Well, the breadcrumbs skip the custom post type. So it ends up looking something like this:

    Home || The Lord of the Rings

    instead of:

    Home | Books | The Lord of the Rings

    Also: Any news on the plugin fix? I need to know if it will be fixed within this week today, so I can inform a client that their site still needs work. Thanks.

  • Ivan
    • The Incredible Code Injector

    Damn, this is some hardcore bug. I've tried hundred different ways to recreate this on my setup and I can't do it.

    That solution does not seem to work. I too cannot click the checkbox for the taxonomy as a SuperAdmin...

    Very strange, SuperAdmin have all capabilities by default. As @afino reported:

    Anyone with SuperAdmin rights is fine but all other users get the Taxonomy error.

    so the taxonomies should at least work for SuperAdmins.

    Has anyone else tried the fix I've suggested ?

    Please share as much details as possible so I can try to hunt down that nasty bug. Please make test only on one setup and give me the details: PHP Version, WordPress Version, MS ( MultiSite ) or SS ( SingleSite ) setup. The user role of the user with which you are experiencing the bug. Screenshot of the edit screen of the taxonomy ( so I can see the settings ). Any specific actions you think that might be relevant.

  • cbesett
    • Flash Drive

    Sorry i'm just now replying to my own thread... :slight_smile:

    I tried the fix about with the addition to cp-core.php to no avail.

    I'm logged in as the admin on a single site (no multi or buddypress.)

    If a dev needs a login i can provide by email.

  • Brayne
    • Flash Drive

    Thank You! Good to see I'm not .... all that nuts...

    I've done a temp work around... I placed the following in my theme's functions.php file....

    register_taxonomy( 'internal_unique', 'post_type', array( 'hierarchical' => true, 'label' => 'My New Categories', 'query_var' => true, 'rewrite' => true ) );

    internal_unique = anything unique for the internal workings....
    post_type = The custom post type I've created with custompress.

    I see an update is on the horizon but I couldn't wait.

    This workaround is for a custom taxonomy that will give the ability for categories for a newly created post_type in custompress. Test First. And It's a temp solution that worked for me.

  • bepe
    • Design Lord, Child of Thor

    I don't intend to sound like a jerk, but the first report on this _critical_ bug was over 50 days ago. :disappointed:
    Ivan found the root of the problem over 30 days ago, promising a minor update, _shortly_ .

    I've already built a site around the functionality of custompress (defining a dozen post types/etc) , but with this bug it's unfit for normal use.

    I understand that maybe he's waiting for WP3.1 to roll out, but come on... give us at least the fix for THIS bug.
    Thanks and sorry to sound so disappointed. :slight_frown:

  • Ivan
    • The Incredible Code Injector

    Hi bepe,

    I apologize for the inconveniences caused by the delay. We are currently updating our entire plugin/theme base for WordPress 3.1 and we have gazillion of task in queue. Next version of CustomPress is 90% ready so you can expect release in the next couple of days ( for real :slight_smile: ).

  • Julian Evans
    • Design Lord, Child of Thor

    I'm also having an issue with custom taxonomies.

    The following error is being displayed in the add taxonomy UI when creating a new post (custom post type created by the plug-in).

    You cannot modify this taxonomy.

    Fresh single site install, WP 3.0.4 running on PHP 5.3. SuperAdmin user role.

    I shall look forward to the fix in the next few days!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.