The apostrophe character in WordPress

My site http://www.olexb.com contains an apostrophe in the site description: OleXb – Dedicated to your child’s success.

It displays like this: OleXb – Dedicated to your child’s success.

It displays correctly when I change it to: OleXb – Dedicated to your child&#39s success.

However, whenever I use Save Options on the Theme Options page, the above change is lost and I have to do it all over again.

Is there a way to fix this?

I am using the Scholar theme.