The copy POSTS content works very sporadically and without any without any pattern.

The plugin is as simple as can be. I select SITE A and then select a number of posts, then select destination SITE B and copy. I always receive the "success" message.

But half of the time, no posts are copied! Some of the time, one post is copied! On one occasion, 3 posts were copied.

I have tried doing one at a time, 5 and even bulk. No pattern. The account I am using has full admin rights to each site AND is a super admin.

Please help.

  • Michael Bissett
    • Recruit

    Hi @Bob Loukas, hope you're doing well today! :slight_smile:

    Are you using a specific subsite as a source site in your testing, or does that not matter?

    Could you name the subsite(s) being used here (both as source & destination sites)?

    Also, could you try replacing this line in your wp-config.php:

    define('WP_DEBUG', false);

    With this:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors',0);

    And then try copying the content again? And could you send over the log file that gets created (should there be anything to report)?

    Please advise,
    Michael

  • Bobby
    • WPMU DEV Initiate

    Hi Michael,

    Yes, I'm trying to go from Site 5 - chartfreak.bigleaguefinance.com to site 6 - chartfreaktest.bigleaguefinance.com

    i did it again, i tried 10 posts to copy, looks like 3 of them came over only. The debug file is attached.

  • Bobby
    • WPMU DEV Initiate

    I went through the conflict process and disabled all network and local plugins. It still behaved the same way.

    Next, I created a BRAND NEW site, site 10 with a default (different theme) and tried to copy 10 posts, 4 of them went over.

    No idea what else to try, nobody has reported such a problem before?

  • Ash
    • WordPress Hacker

    Hello @Bob Loukas

    I hope you are well today.

    No idea what else to try, nobody has reported such a problem before?

    Honestly, I didn't find any similar report before :slight_frown:

    Also, would you please let me know as I asked: And who is your host? What is your memory limit?

    New question, is it a shared hosting?

    Also, would you please try to use the following line in wp-config.php:

    define( 'WP_MEMORY_LIMIT', '256M' );

    Please let us know.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.