The count of votes per post remains zero, after votes have taken place.

On URL:
http://starfleetcomms.com/how-to-make-a-post-update-your-profile-and-post-on-the-wall/

There is one vote on that article, my vote. That vote shows when you are logged in, when you are not logged in it shows as 0 votes having being logged.

  • John
    • WPMU DEV Initiate

    Hi
    I saw that someone named Luis had gained access and made some changes to the site, disabling plugins and css and so on which meant that I had to re-enable Google webmaster tools and re-enter the meta code.

    This was my mistake in allowing you access to my production site. Please note I have revoked that access (after the hour should have expired) and instead copied the production site over to staging here: http://staging2.starfleetcomms.com

    Please use this site for fault diagnosis now, access has been granted. Also note that the Post Vote plugin on the activity page goes awry if you logout on this URL, pointing to css compatibility issues with Buddypress. http://staging2.starfleetcomms.com/activity/

    Anyway, on production I have disabled this plugin once again until resolved.

  • Sajid
    • DEV MAN’s Sidekick

    Hi @John

    Hope you are doing good today :slight_smile:

    Yes, it because you have disabled voting from unregistered users. To allow visitors to vote then enable Allow voting for unregistered users from Settings > Post Voting.

    Would not that work for you ?

    Cheers, Sajid

  • John
    • WPMU DEV Initiate

    No that wouldn't work.

    One of the features of the plugin is to disable voting from unregistered users to therefore drive people to register to take part in voting.The fact that the number of votes showing is incorrect gives users passing by the indication that there is no interest in the post and they would be less inclined to register to vote. It should be showing the correct number of votes on a topic. It is after all a post votes plugin.

    Allowing unregistered people to vote removes the drive for people to register login, removes the tracking of user votes on the activity wall and calls into question the functionality that setting was surely designed for.

    If you wish to formally disable this as a feature of the plugin then it should be removed from the advertising. All I wish to do is use the plugin as advertised. I look forward to it being fixed. Meanwhile, it is not fit for my purposes and judging by some of the comments here it is in need of some general maintenance.

  • Sajid
    • DEV MAN’s Sidekick

    Hi @John

    Hope you are doing good today :slight_smile:

    Yup, it seems there is issue with the code of plugin. I messed with the code and found out the culprit. The issue is causing because there is no blog id specified.

    I have patched the plugin and attaching a file for you too. Please download the attached file "class_wdpv_codec.zip", extract/unzip it and move "class_wdpv_codec.php" file to following location by replacing the existing one via FTP.

    wp-content/plugins/wpmu-dev-post-votes/lib/

    It would be great if you reconsider the vote to upward from down :slight_smile:

    Hope it helps :slight_smile: Or feel free to post a reply if needed.

    Cheers, Sajid

  • John
    • WPMU DEV Initiate

    Hi Sajid.
    That works very well. Thank you for the fix to the code. I've had to stop the login option appearing on the activity stream of my site using CSS but that is not related to the query I raised with you.
    Overall I am very happy with the fix and wish to thank you for delivering it.
    Thanks Sajid!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.