The "Create User" button is inactive

For some reason, my ability to create a new member in M2 is disabled.

I go to Add Member in the M2 admin menu. I fill in all the fields, using a secure password, no prohibited strings in username, but the button remains greyed out and I get a "no way" symbol when I try to hover or click.

I can't tell if I accidentally locked myself out of something or... ???

Hoping someone can double check me here...as I'm having difficulty setting up my user permissions, so maybe something is more messed up than I realize. :\

  • Vinod Dalvi

    Hi @kalic,

    Welcome to the WPMU Dev community and thanks for posting on the forum.

    I could confirm the issue on your site by logging in to it using support staff access but it's working fine on my test site using same latest version of Membership 2 Pro plugin.

    Please see the first screenshot taken from your site where 1 is appended to fields but it's not appending on my site as shown in the second attached screenshot.

    This can be due to plugin/theme conflict on your site.

    You can just try on your development site temporary using default WordPress theme like Twenty Fifteen and temporary deactivating all other plugins and activating them one by one as displayed in the following flowchart to know which theme/plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    Best Regards,
    Vinod Dalvi

  • mabraham1

    I've deactivated every plugin on every subsite. I'm down to M2 (which is network enabled at the wp-config level, fwiw) and of course WPMUDEV Dashboard.

    The strange thing is, I can't deactivate M2. It says it's deactivated, but it's still activated. See screenshot for the results taken immediately after clicking "Network Deactivate".

    Since I need to test M2 anyway, I went ahead and tried to create a new member. It basically worked: I put in a username and an email address, the ajax check did not cause a 1 to show up after the field...then first and last name....and I noticed that the "create" button had activated.

    So just to see which field activated it, I backed up.....removed the last name, then the first name, and then the email address. As soon as the email address was removed, M2 did it's ajax check of the blank, and I got an error message where the 1 had shown up before! See screenshot.

    I can only figure that this error is coming from M2 itself...as there are no plugins activated, theme is 2015, and it seems to be the result of the M2 ajax check. Or perhaps the ajax verification is WP based? But I'm hoping maybe I'm overlooking something. Any ideas?

  • mabraham1

    Well, I've been thinking something was wrong, and now things are really wrong. I'm starting to think that two weeks of work were wasted, and this plugin just doesn't work right. I truly hope I am wrong, because it's one of the main reasons we got our WPMUDEV membership.

    So here's what happened.....

    I finally disabled M2 by changing the name of the plugin folder, then changing it back. Immediately, I noticed that the plugin had an update available: 4.0.0.5. This reminded me that--as you can see in the screenshot--I was getting messages that I had v. 1.0.1.1 just before I deactivated it. I didn't recognize them as being a bad sign, since I wasn't really aware of what version I had.

    So apparently, when I deactivated it multiple times (and it refused to actually deactivate) it somehow ended up reverting to an older version (which, incidentally, I don't believe I ever had installed; the first time I installed this plugin was just a week or two ago. All indications are that it was well beyond v. 1.0.1.1).

    Anyway, I had no choice but to follow along, and I ran the update to 4.0.0.5.

    Then my next step was then to look at the settings. But now it's not showing up in the main site (of the multisite) admin menu. But it IS in all the subsites.

    So I go check out the settings for one, then another, and it turns out they all say the same thing: I have to click a big button to update to the new version, and it's going to do a conversion of my old data. But when it finishes, it doesn't seem to have any of my data (membership plans, etc) saved at all. And it's not network-wide, even though I have MS_PROTECT_NETWORK enabled in wp-config.

    Because I can't wait on a fix, and it's entirely foobar at this point, I'm probably going to delete the entire folder and redownload it, and see what happens.

  • Kasia Swiderska

    Hello kalico,

    Did you test earlier free version of Membership form wordpress.org repository? This problem with update to the 4.0.0.5. would suggest that.
    Can you please try to delete folder, and install Membership from WPMUDEV Dashboard, not otherwise?
    Please don't update to 4.0.0.5 version if this update will show again.
    If you will have more problems, please write and re grant support access.

    Kind regards,
    Kasia

  • mabraham1

    Hi Kasia,

    I think I may have installed the free version, but I don't recall for sure. I tested a lot of membership plugins at one time, so it's likely. I suspected that might be the problem; however, things got so bad that I decided to do as you later suggested: delete and reinstall. After I did that, the old version still came up first.

    I have actually moved this issue to another thread (sorry for not following up here) because it ended up so far from where it began as to be useless for others under this title. So if you want to see what happened/is happening, you can check it out here.

    In the end, with the "create new user" button, I figured out a few things:

    1. the ajax validation routine seems to be what's causing the 1 or the 0:validate:required next to the field.

    2. even with all other plugins deactivated except M2, the validation would still show up to the right of the field

    3. I had disabled BuddyPress, but had NOT disabled the BuddyPress M2 Addon. Furthermore, I had not disabled the additional features of the BuddyPress M2 Addon. Somehow, I suspect that combination of scenarios was influencing the way that admin-level registration page works. Just a guess. It seemed to get better when that was all fully disabled. I had to re-enable the Addon, then disable the registration feature, then re-dis-able the addon. After all that, the validation 1/0 stopped displaying.

    It all seemed very buggy, but not the same bugginess as the M2 version concerns, which are being handled in the other thread I reference.

    So I this might be worth a note to the dev team to see if they can replicate my experience and fix this issue, specifically the "create new user" button not working properly.

    Thanks :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.