The Events Calendar plugin don't show the tickets option if Membership 2 is enabled

I'm having an issue with Membership 2 plugin working with 'The Events Calendar' by Modern Tribe. The issue is that - on Event pages, there is a "tickets" area at the bottom of events and this only shows up to logged in users.

However, when Membership 2 is activated, only Admins and Editors see the tickets, members who are subscribers don't.
As soon as I deactivate that, subscriber users can see the tickets.

Please advice.

  • Ari
    • Recruit

    Hey Sarah

    Hope you are fine today!

    I could replicate the issue in your staging site, for testing purpose I had to remove lot of membership data, and finally I could solve the issue - but still I need to further test it.

    We have some hidden memberships in our plugin for functionality purpose, we call it system/base membership.

    This system membership is revoking the access of that RSVP form, after manually reset that membership, issues seems resolved, though it requires further testing in case if it causes other side effect.

    So, can you please regenerate the staging site for me for further testing with real data?
    Also keep the same login access, but if you change it, send me the login credentials through our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question
    Using the below template:

    Subject: "Attn: Ari"
    - WordPress admin (login url/username/password)
    - FTP credentials (host/username/password)
    - cPanel/Plesk credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    Regards,
    Ari

  • Sarah
    • Design Lord, Child of Thor

    Hi Ari, I'm so sorry, I missed this response from you.
    I'm so glad to hear you might have worked it out. I have reset the staging site and have set up new creds, which I have sent via the form you asked me to send it in. Please let me know if you need anything else from me.

    Thanks again
    Sarah

  • Ari
    • Recruit

    Hey Sarah

    I fixed the issue in staging site by reset the base/system memberships, can you please check if everything is fine in the staging site?

    If you find everything fine on staging site, lets do this fix in the live site too, so please follow the below steps:

    1: Take a backup of your live site.
    2: Download the attached file, Upzip it, upload it to wp-content/mu-plugins folder, If you don't find the mu-plugins folder, just create it.
    3: Refresh the page. Make sure you are logged in as admin. It may need some time to reload the page.
    4: Delete that file from mu-plugins folder.

    Now please check if the issue got resolved!

    Best Regards,
    Ari

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.