The export of sidebar from subsite won't import

I am trying to import some custom sidebars from one subsite to another but it looks like it is not working.
Please see json file inside chat.

  • Katya Tsihotska
    • Support & QA

    Hi mpress

    Hope you are doing fine today!

    I've checked your JSON file and found that there are some errors here. There are missed two last brackets. But even when I fixed this, this file didn't to work anyway. So, I think we need to ask help from our SLS (code expert). I suppose that there is some special content in this file that causes the issue.

    Keep in mind, SLS deals with more complex threads so it might take them a little longer than a normal ticket to reply.

    Meantime, could you try to perform plugin conflict test to make sure that issue isn't caused by some other plugin? Disable all plugins and try to download the export file again and then try to import it. If it helps, you need to activate all plugins one by one and check which of them will make the issue appear again. Let me know about results, please.

    Kind regards,
    Katya

  • Panos
    • SLS

    Hi mpress ,

    While I was wondering if some characters should be escaped (\r\n to be precise included in the css of the "Recent Posts Extended" widget), simply renaming the file seems to be importing

    Could you please test the attached file? It' the original file renamed. Could you also let us know if it works? I tried it out in your site and I could reach the preview step after selecting file. I didn't complete the import though since I'm not sure this is a test site or not.

    Thanks!

  • mpress
    • Code Wrangler

    Hi Panos ,

    It sounds weird, that just changing file name it works... Thanks for not importing. some widgets/sidebars were not to be imported :slight_smile:. I had already changed some of them mannualy.
    I was to able to see and import file this time. Before I could not even see the preview page.
    "Recent Posts Extended" widgets were bit messy, wrong category chosen when importing, but they were there. We have so far only 2 category, when importing it came with the wrong one.
    Now I just need to check links because they are pointing to the other subsite.

    Cheers,

    ps: i donot understand this:

    While I was wondering if some characters should be escaped (\r\n to be precise included in the css of the "Recent Posts Extended" widget)

    and when importing I was bit confused with that "export file" after the Import title. what does it mean?
    see picture

  • Panos
    • SLS

    Strange indeed! What I actually did is I created a blank json file and copied the content, so it might have to do with encoding.

    Regarding the "\r\n", I supposed you already noticed it, that's why I mentioned it. These characters are used to add a new line, you won't see these characters in the text, you simply see a new line. In some widgets there was some css code in the text areas which contain new lines (the characters I mentioned). I noticed that they were not escaped, so I tried by escaping them.

    The "Export file" probably is a typo. It would be less misleading if it said something like "Exported file", or "Choose the exported file". Thanks for bringing this up, I 'll inform the developer about it.

    Cheers!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.