The facebook comment not enabled

I trying to publish the comments inside the page i create with upfront and is not working. I follow all the configurations and all is set, please what i miss in my settings.

  • Kasia Swiderska
    • Support nomad

    Hello GFireM,

    I checked your blogs posts and it looks like there is no comment element there. Comments+ adds options for login to comments only when comments are on post.
    I tested that on my site and Comments+ options are showing correctly

    And Facebook login also works correctly.

    There has to be Comment Post data element under post

    if that is not the case would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • apurba_podder
    • Site Builder, Child of Zeus

    Hello GFireM,

    Hope you are doing good today. :slight_smile:

    I have gone through you website. After investigating I seen that Comments Plus is working properly. Please make sure your Facebook app is set to public. Now the app is in development mode. So no one will be able to comment with this apps. Please visit this page . I have implemented Comments plus in the post.

    To set you Facebook apps as public , click on the question mark, (please see the picture below)

    Click No before “Your app is in development and unavailable to the public” and slide it to Yes

    Finally Click confirm & save change.

    Hope your problem will be solved. Take care;

    Best regards
    Apurba

  • GFireM
    • The Incredible Code Injector

    Hi, thanks for your help, and sorry for my delay. I publish the facebook app, and the comment only show in one page, and not sure if is from the comment plus plugins because i only limit to comment with facebook and the box in the page grant to comment with wordpress, twitter, google and facebook. Can you help me please, why the other pages dont show the comment box.

  • GFireM
    • The Incredible Code Injector

    Hi. Thanks for your help. I enabled the support access. I add the comment component inside the page. It show only the no comment page message, no ahow the form. But it only show in one page. I will preciate all your help.

  • apurba_podder
    • Site Builder, Child of Zeus

    Hello GFireM,

    Sorry for the inconvenience .

    I publish the facebook app, and the comment only show in one page,

    Since WordPress 4.3, comments are turned off on pages by default. To allow comment on page have to select allow comment option from discussion . Please see the attached Screenshot.


    i only limit to comment with facebook and the box in the page grant to comment with wordpress, twitter, google and facebook.

    Have to select the option which one you don't want to display. I have selected every option without Facebook on behalf you. Now it is working fine.

    Comment with Facebook option is not working properly. I was able to replicate the issue in my test site.I'll report this to our developers so they can investigate this further and fix in one of the following plugin updates. In the meantime please use other option to comment with.

    I appreciate your patience. Thanks for reporting the issue.

    Kind Regards
    Apurba

  • Kasia Swiderska
    • Support nomad

    Hello GFireM,

    This is issue that Apurba reported to developer as he was able to replicate the same problem on his site.
    That is why he recommend using other options to leave comment (for example default WordPress).
    As soon there will be fix for that issue we will let you know.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.