The "Global header" is Stuck in Spirit Theme/Upfront

Team WPMU,

I tried to see what "set as global header" would do -- didn't like it -- and tried to switch it all back by unselecting the global header option. However, not only will it not change back, it has enforced the now global header on all new pages being created.

How can I stop this? I'd like it to go back how it was -- and the "undo" isn't working anymore.