the iframes on pages

the iframes on pages http://www.silverdoorspa.com/request-appointment/
http://www.silverdoorspa.com/shop/
http://www.silverdoorspa.com/gift-certificates/
won't show in Firefox since we updated upfront. This is regardless if placed in an upfront module or in the wordpress backend

  • Predrag Dubajic
    • Support

    Hey Synergyclique,

    Hope you're doing well today :slight_smile:

    Would you mind allowing support access so we can have a closer look at this as I was unable to replicate the same issue on my installation while I do see it on your end?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please respond in this thread once access is granted.

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Synergyclique,

    Thanks for granting access, I did few tests on your site and it looks like that this is not related to Upfront update or Upfront at all.

    I have created new page on your site with different iframe and it was working on FF with Upfront active, so I checked your Gift Certificates page with default WP theme and again FF didn't show anything.

    I also just updated my FF version and after that I can see this error in console:
    Load denied by X-Frame-Options: URL_IN_IFRAME does not permit cross-origin framing.

    This usually means that the host of the site you are trying to use in iframe is blocking this.

    Is the site you are linking in iframe your site as well?

    Best regards,
    Predrag

  • Synergyclique
    • Site Builder, Child of Zeus

    I also just updated my FF version and after that I can see this error in console:
    Load denied by X-Frame-Options: URL_IN_IFRAME does not permit cross-origin framing.

    You just literally admitted that the updated version of upfront isn't working with the new version of Firefox. We did our own test as well; we FTP's an older version of upfront, and the iframe showed fine in FF. In the two years, I've been a customer; I ve seen this platform come a long way. But not once, and I mean not once. Have you guys ever admitted you have had an error. Not trying to be rude, but this is about my client. Please try to take this serious.

  • Predrag Dubajic
    • Support

    Hi Synergyclique,

    You just literally admitted that the updated version of upfront isn't working with the new version of Firefox. We did our own test as well; we FTP's an older version of upfront, and the iframe showed fine in FF. In the two years, I've been a customer; I ve seen this platform come a long way. But not once, and I mean not once. Have you guys ever admitted you have had an error. Not trying to be rude, but this is about my client. Please try to take this serious.

    I'm sorry if it looked like I was not taking this seriously, I was simply trying to explore this issue from different angles.

    I mentioned above that I updated Firefox while testing your site as version 46 was not installed on my machine and that's when I saw the error.
    However, as I mentioned above I saw same issue on your site even with the default WP theme, and that's why I believe that the issue is not Upfront related.
    I also tested my own installation of UF with some iframes from Youtube and embedded site but I was unable to replicate it on my end.

    We acknowledge all bugs related to Upfront and you surely noticed improvements in Upfront since its release, I would gladly report this to our devs if it turns out it is Upfront issue but I need some more info that I could give them.

    Could you please switch to default WP theme and visit your /gift-certificates/ page and tell me if you're able to see the iframe working there?

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Synergyclique,

    Sorry to hear you have decided to switch themes.

    It's strange that it showing for you, when I checked your site with 2014 theme the iframe was still not showing, could be because I'm using FF on Mac.

    If you decide to stick with the theme bit longer I would be happy to perform few more tests to see how the issue can be replicated and report it to Upfront developers.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.