The instructions are not helping... lol please help with setup of membership

I have started to protect content on my site and I am trying to follow every single step on the instructions page. Only thing is that the image they show is not in the option they show. I am trying to protect pages but its not giving me the option to do this. This was the step one on the site where it says protect content first.

Second issue is on the page I have I tried to click the enable protection toggle and when I did and picked a membership, after I hit the update button it just turns it off and removes what I chose.

What am i doing wrong here... thanks

  • Michael Bissett

    Hey @Jason! :slight_smile:

    Only thing is that the image they show is not in the option they show. I am trying to protect pages but its not giving me the option to do this. This was the step one on the site where it says protect content first.

    Those instructions definitely need an update, as the interface has changed quite a bit since then. In the meantime though, I've attached a quick screencast that'll show how to add a page to a membership:

    http://screencast.com/t/b1mETr3wCY6

    Second issue is on the page I have I tried to click the enable protection toggle and when I did and picked a membership, after I hit the update button it just turns it off and removes what I chose.

    Here is the message i am getting on the single page post.

    While we have come up with an issue like this (for which we have a fix, it's being reviewed presently), that error you're seeing there is due to the fact that no membership levels have been created yet inside of Protected Content.

    You'd want to go to:

    Protect Content -> Memberships

    And create a new membership from there. :slight_smile:

    Hope this helps!

    Kind Regards,
    Michael

  • Jason

    Thank you so much for your reply!!! and the first option worked but the second issue still remains for me.

    On the individual pages it wont let me use that option weather there is a level or not. I tried with two levels that were created I just deleted them and tried again. You happen to get the screen shot where there was not a level. But it didnt work for either option. Let me know what the next step on that should be.

    thanks

  • Michael Bissett

    Hey @Jason,

    On the individual pages it wont let me use that option weather there is a level or not.

    Which would be due to the bug that I mentioned earlier (which we have a fix for, it's just being reviewed at this point). :slight_smile:

    The rest of my reply was targeting the fact that you were seeing that Warning on the page, and having a membership created would cause that warning to go away. As for being able to enable/disable the protection on individual pages through the "Edit Page" screen for a page, we'll need to wait on the release of the bugfix.

    In the meantime though, you can set up the protection of the pages on your site through the area that I illustrated in the screencast shared earlier. :slight_smile:

    Hope this helps!

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.