The languages are now working as far as I can see

First I realize the language pack is not a plugin and have uploaded all the languages per instructions to a languages folder inside my wp-contents folder

I don't see any options on the network admin to choose default language and I also added the choose language at sign up and set up a test account and saw nothing there either

Can see what might be the problem?

http://www.thevintagejewelrychick.com

I have granted access via the dashboard for support.

Thanks so much
Cheri Faline