The Multi-Domains plugin is only compatible with WordPress Multisite.

I am getting the message saying:

"The Multi-Domains plugin is only compatible with WordPress Multisite."

But i activated the WordPress Multisite by adding the line
define('WP_ALLOW_MULTISITE', true);

at my wp-config.php file. And i can see "Network Setup" menu item at my "Tools" menu.
When i upload the plugin files, getting the message. What is the problem?
Thanks