the multisite plugin does not work with some domains

Previously it had installed WordPress MU Domain Mapping plugin and worked well, now I changed to yours and has several things that do not work:

1. http://www.queputescerques.cat takes you to the web leads to registration
2. http://www.elblogdeukume.com feels the same as for part 1
3. if active for all domains using www loop fails
4. If activated for SSO gives me error loop

  • Tyler Postle

    Hey Lorenzo,

    Hope your'e doing well today.

    Would you be able to send in your wp-admin so I can look at your subsite settings too? Since they are mapped I'm only able to access the main site through our support login. If you could include FTP that would be helpful too - would allow us to troubleshoot further after we've had a look at your settings.

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Look forward to hearing back.

    Cheers,
    Tyler

  • Tyler Postle

    Hey Lorenzo,

    Thanks for sending that info in. I can see you have a bunch of htaccess rules to redirect domains. This is likely going to conflict with Domain Mapping. With our Domain Mapping plugin you can map both the www. and non www and direct one to the other - so our plugin already manages that.

    I'm not sure what other rules you have in there, but I would recommend clearing out all your custom rewrite rules and then we can see what issues are still remaining - then once we have everything sorted out you can re-add them, if needed.

    I could temporarily remove those for you but just want to make sure that's okay with you before editing anything in your .htaccess.

    Look forward to hearing back.

    Cheers,
    Tyler

  • MrUkume

    Hola, Tras unas comprobaciones y cambios esto es lo que hay que cambiar y no me deja o no esta correcto.

    1.- entu.red -> si vas a entu.red sin www me va a la pagina de registro y no a http://www.entu.red
    2.- ocionews.com -> si vas a ocionews.com carga la portada sin www debería cargar con www ahora bien cuando haces clic en cualquier enlace si que te manda a la url con www
    3.- tgnavui.com -> funciona correctamente
    4.- megustawaze.com -> funciona correctamente
    5.- queputescerques.cat -> me lleva a www independientemente la opción activada
    6.- elpetitdetallsalou.com -> me lleva segun la url que ponga (con o sin www) da igual como lo configure, deberia llevar al www
    7.- elblogdeukume.com -> me lleva a www independientemente la opción activada

    Gracias

    ------------

    Hi, After a few checks and updates this is what needs to be changed and will not let me or not right.

    1. entu.red -> if you go to www entu.red without me going to the registration page and not http://www.entu.red
    2. ocionews.com -> if you are loading the cover ocionews.com should bear no www www Now when you click on any link if you send the url with www
    3. tgnavui.com -> working properly
    4. megustawaze.com -> working properly
    5. queputescerques.cat -> brings me to www regardless the activated option
    6. elpetitdetallsalou.com -> leads me to put according to url (with or without www) does not matter as set, should lead to www
    7. elblogdeukume.com -> brings me to www regardless the activated option

    Thank you

  • Tyler Postle

    Hey Lorenzo,

    Sorry for my delay here

    This is odd, even when you don't have any domains mapped your subsites still have a mapped domain.

    I'm wondering if this is a conflict between your existing domain mapping db tables from when you were using the wp.org domain mapping plugin.

    Can you backup your site then clear your domain_mapping tables? This will clear your mapped domains so you can re-add them.

    If you don't already have a backup plugin you can use our Snapshot Plugin to do the backup.

    If you're unsure about editing anything in the db yourself then do you mind sending in your cPanel credentials so we can access your phpmyadmin?

    You can send that privately through our contact form again same as last time: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Tyler Postle"
    -cPanel login url
    -cPanel username
    -cPanel password
    -link back to this thread for reference
    -any other relevant urls

    2. ocionews.com -> if you are loading the cover ocionews.com should bear no www www Now when you click on any link if you send the url with www

    So you want the home page to have no www but then you want individual pages to have www? Or you just want the whole site to be non-www?

    Talk to you soon! Cheers

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.