The Mysterious Twitter Auto-Feed populated in my posts

Whenever I make a new post, and there is a link to my twitter on that page, WordPress appears to be automatically replacing that link to Twitter with a full-width Twitter feed instead. I DO NOT want that. I want to disable it. Problem is, I cannot figure out what is causing it. I've even disabled all my plugins, and the SOB still appears.

The site is here: http://hottipsmedia.com

It doesn't appear on all of the posts... just the latest ones. I look at posts a few months back, and the site is NOT doing that to the links. Older posts look at intended. For some reason, WordPress is pretty much ruining my posts lately by embedding my Twitter, which I do not want. To my knowledge, I've added no functionality that does this, and none of my plugins appear to be doing is, as I've tried posting a new article with NO plugins on, and it still shows up now.

How do I turn this off so that it never comes back, anywhere, again? Thanks! Support access has been granted already.

  • James Morris

    Hello Charlie Pryor,

    I hope you are well today.

    This functionality is native to WordPress. It has been since version 4.4. I'm not quite sure why you're just now seeing this. However, this can be disabled by adding the following to your theme's functions.php file:

    remove_shortcode( 'embed' );
    remove_filter( 'the_content', [ $GLOBALS['wp_embed'], 'autoembed' ], 8 );
    remove_filter( 'the_content', [ $GLOBALS['wp_embed'], 'run_shortcode' ], 8 );
    remove_action( 'edit_form_advanced', [ $GLOBALS['wp_embed'], 'maybe_run_ajax_cache' ] );

    I hope this clarifies a bit.

    Best regards,

    James Morris

    • Charlie Pryor

      That appears to have done it, thank you! I have never seen this happen before on any of my sites, and they are all WP 4.6+ right now. I recently did an update to 4.7 and then this started happening. I updated a few plugins at the same time, so I thought perhaps it could be them - but when I viewed the site with none of them on, and it still happened, I kinda figured it was either the theme, or core.

      I'm not sure what else this removes.. looks like the entire embed shortcode? I suppose since I'm not using it, it doesn't matter, but it would have been a shame to disable that entire shortcode due to not wanting one thing to work that way.

      In any case, issue resolved. Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.