The noreply@domain.com is listing the wrong domain

The noreply@domain.com is listing the wrong domain in the email being sent out from our Multisite instance. The site seems to be sending all of the email from one blog URL, despite being active on multiple sites. I've created a short video to help display the issue:

http://www.screencast.com/t/TWmovzOr

  • Michael Bissett

    Hi @mrjarbenne, hope you're doing well this evening! :slight_smile:

    Do you happen to have Subscribe by Email enabled on your main site? If so, could you check to see if the no-reply domain that's shown in your screencast is the one set in Settings -> Subscribe by Email inside the Network Dashboard?

    (I know that the plugin isn't Network activated on your Multisite, but if the plugin is active on your main site, then you will see this menu inside the Network Dashboard)

    If it's not showing there, then it looks like we'll need to take a deeper look at things here. In that case, could you please send in the following:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details
    - Include FTP log-in details (just in case)
    - Include cPanel details (will need to access the database, so phpMyAdmin or equivalent will be required)
    - Include any relevant URLs for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Looking forward to your feedback! :slight_smile:

    Kind Regards,
    Michael

  • mrjarbenne

    Do you happen to have Subscribe by Email enabled on your main site? If so, could you check to see if the no-reply domain that's shown in your screencast is the one set in Settings -> Subscribe by Email inside the Network Dashboard?

    (I know that the plugin isn't Network activated on your Multisite, but if the plugin is active on your main site, then you will see this menu inside the Network Dashboard)

    I didn't, but once I did, and checked the Network Settings panel, the domain was the wrong one. I changed it to the root domain. I'm not sure how that blog URL would have populated that space, but that may be the easy fix, which is good, because most of the other things you needed are locked behind a firewall and require VPN access.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.