The package could not be installed. PCLZIP_ERR_READ_OPEN_FAIL (-2)

When using the wp plugin installer and uploading the file from my computer, I get this for each of the plugins I have tried to install :
Unpacking the package…

The package could not be installed. PCLZIP_ERR_READ_OPEN_FAIL (-2) : Unable to read archive '/home/design/public_html/wp-content/uploads/2016/03/391205_integrated-video-tutorials-1.5.21.zip'

What change/changes do I need to make to allow this to work?