the page have too many server redirect

Hi,
I was using Multisite everything work fine until I changed the domain of the WHM/Cpanel. after change the domain name, user, rename database name.
I also go to wp-config to change to the right database name
MySQL database username */
define('DB_USER', 'thoinay_one');

/** MySQL database password */
define('DB_PASSWORD', 'Dubeysoham1');

/** MySQL hostname */
define('DB_HOST', 'localhost');

and change this define('DOMAIN_CURRENT_SITE', 'thoinayonline.com');

and I got this ERR_TOO_MANY_REDIRECTS

This webpage has a redirect loop

Reload Less
The webpage at http://thoinayonline.com/wp-signup.php?new=thoinayonline.com has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.
Learn more about this problem.
Error code: ERR_TOO_MANY_REDIRECTS.

Please help.

  • Jack Kitterhing
    • Code Norris

    Hi there @Melvin,

    Hope you're well today and sorry to see of the issues your having here.

    So you changed the whole database for the site and not just the domain?

    What do you have in wp_options for the site URL?

    Have you run a find and replace on the database to replace the URL?

    Could you paste your .htaccess here please? Is this sub directory or sub domains? :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • Melvin
    • Flash Drive

    Hi Jack

    here is my .htaccess

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    When I modify the account I changed domain name and the users. unfortunately the database didn't copy to new user so I was advised to rename database.

    What do you have in wp_options for the site URL? ---> I don't know where to go to this file.

    Have you run a find and replace on the database to replace the URL?

    I try to run search and replace but I got an error.

    Warning: Creating default object from empty value in /home/thoinay/public_html/wp-includes/ms-settings.php on line 111
    Warning: Cannot modify header information - headers already sent by (output started at /home/thoinay/public_html/wp-includes/ms-settings.php:111) in /home/thoinay/public_html/Search-Replace-DB-master/index.php on line 347
    --------------
    The scrip encountered an error while running an AJAX request. If you are using your hosts file to map a domain try browsing via the IP address directly. If you are still running into problem we recommend trying CLI script bundled with this package. See readme for details

    I upload the file in root folder and access the file by web browser and got the error message.

  • Jack Kitterhing
    • Code Norris

    Hi there Melvin,

    Thanks for the additional information :slight_smile:

    wp_options can be found in your database using phpmyadmin or similar :slight_smile:

    On the find and replace which script did you try? I'd recommend trying this database script here https://github.com/interconnectit/Search-Replace-DB

    Could you let me know which version of WordPress you activated multisite on originally?

    Thanks!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.