The plug-in WP Smush Pro still does not work in my website

Hello, I had on my website free version of Smush, then bought the WP Smush Pro, but when installing and configuring the dashboard and API, the plug-in still does not work ... it gets stuck when starting. It sticks to the same number of images. Can you help me?

  • Michelle Shull

    Hi there, Natalia!

    I can try to help!

    First off, did you remove the free version of Smush before you installed/activated Pro? If not, do that now and your problem should be sorted.

    If that's not it, would you mind doing a quick plugin conflict test? We outline some great troubleshooting steps in our manual, here: https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    When you used the free version, did everything work as you expected it to?

    Thanks!

  • Natalia Franco

    Hello Michelle; thanks for your answer.
    In the Free version it worked well...until I activated the pro version.
    I uninstalled the free version, the pro version also dashboard plugin ... and install again the pro version again, deactivated all plugins and put the WordPress default theme Twenty Fourteen Versión : 1.4 but not work, I definitely think it's plugin or something in server configuration ... the strange thing is that work from the media library, but not working in Bulk. Any ideas?
    Thanks

  • Michelle Shull

    Hi Natalia!

    If it's only doing the bulk smush, I suspect your server memory is timing out. I've got a few different fixes you can try to increase this amount. You'll need to look at your wp-config.php file first. You'll find it in the root folder where you have WordPress installed.

    In wp.config, edit the existing memory limit or add this line:
    define('WP_MEMORY_LIMIT', '128M');

    If you're on a dedicated server and you can access the php.ini file on your server, which some hosts don't allow, you can edit the PHP memory limit by changing this line:

    memory_limit = 128M ; Maximum amount of memory a script may consume (128MB)

    If you can not access this file, you can try adding this line to your .htaccess file, which will also be in the root WordPress folder:

    php_value memory_limit 128M

    If none of these options work, you can try talking to your host about increasing your memory limit.

    Once you've got enough memory allotted, you should be able to complete Smushing successfully. :slight_smile:

    Hope this helps!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.