The progress is not changing on the courses now

In the course unit menu the check box:
User needs to answer all mandatory assessments and view all pages in order to access the next unit

worked before but does not progress any more. It use to work after the student did what was requested and then clicked the DONE button. Now it will not tell you what % you have finished it stays at 0%
Can you help?

  • Tyler Postle
    • CGO

    Hey iBabko,

    Hope you're doing well today and thanks for your question!

    I just tested this on my own installation and it still seems to be working as expected. Have you also checked the box to require the unit be "passed" to open the next one? Perhaps the unit doesn't have a passing grade, or it's one that needs to be assessed by the instructor and issued a grade.

    If that's the case either then can you grant support access so I can take a closer look at the settings?

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    Look forward to hearing back!

    All the best,
    Tyler

  • iBabko
    • Site Builder, Child of Zeus

    Yes I checked the box to be passed.
    What I noticed since the last update the the little clock that shows progression is not updating when it use to update in %.

    Even when I uncheck the box the % never gets to 100% nor does it get to any % whether checked or unchecked.

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey there, iBabko!

    I just ran a quick test on two of my sites, and I can see my progress through course units properly on both sites.

    Would you mind re-activating support access? You're at the top of our queue now, so the response should be pretty quick.

    Also, have you installed any new plugins/themes that may correspond with the time you started seeing this error?

    Thanks, iBabko! We'll get you sorted. : )

  • Tyler Postle
    • CGO

    Hey iBabko,

    Thanks for getting back to us!

    I tested this further to try to reproduce the issue and still can't see the issue. Do you have any caching plugins active? I would try doing a full plugin conflict check just to be sure.

    Also turning on wp_debug in your wp-config.php would help too in-case any errors are happening.

    You will want to set this line to true:

    define( 'WP_DEBUG', true );

    Or add it if it doesn't exist.

    Let me know if this reveals any further info :slight_smile:

    Look forward to hearing back!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.