The sign up Process

When a person goes to sign up for a subscription, the process seems more cumbersome than necessary.

Basically you go the the initial sign up page (in my case
1. Choose a subscription (I have three levels to choose from)
2. Register (if you're a new user)
3. Choose the subscription plan (again)
4. Go to another page where you click the "PayPal" button that takes you to the Paypal page.

This could all be accomplished in two steps
1. Register or login
2. Choose a subscription level and have it take you immediately to PayPal.

I'm on WordPress 3.3.1, Membership 3-RC-1, I have only activated the PayPal solo payment gateway.

Is there anything I can do to simplify the process? or is this just the way it has to be?

  • aecnu

    Greetings elliottdesign,

    Thank you for this great feedback, it is appreciated and acknowledged.

    I completely understand the logic behind this feedback and from an Internet Marketer perspective appreciate the more clicks the end user has to make in the sales process the more likely you are to lose them.

    However, being that I am not the coder of the Membership plugin and do not know the intimacies of the code within, I must refer this over to the lead developer of the Membership plugin for his due consideration and hopefully he sees it the same way as we do.

    Therefore I shall move this over to Feature Requests and alert the lead developer of the request.

    Thanks again for this great piece of feedback and for being a WPMU Dev Member!

    Cheers, Joe

  • KevinDLyons


    It sounds like you have one step too many there. Our process is:

    1. Choose subscription
    2. Process a registration (I'm using Gravity forms + BuddyPress)
    3. Land on payment page (Authorizenet)

    It seems like even with PayPal you shouldn't have to do step 3. It may be possible that the parameters on your subscription link may be falling off during registration. For example, my subscription page where I have the [subscriptionform] shortcode is "member-registration" and when you choose the first subscription option the link looks like:

    Also, if you are using SSL for your registration/login process you should force the page with the [subscriptionform] shortcode to only render in SSL/https. Otherwise when the user traverses from http tp https it breaks the session. I'm using the "WordPress HTTPS" which works great.

    Hope this helps.

  • elliottdesign

    Thanks Kevin.

    Yeah, the process changes when I activate the gateway. But that doesn't seem to be working so I'm trying to get things going with PayPal until I can get some resolution on the issue.

    I am using WordPress HTTPS to force SSL on those pages. It appears to be keeping the query string intact through the whole process.


    I don't think what I'm asking for is a feature request nor is it merely a marketing concern (although it is that, as well). It's showing the exact same page twice in the process. To me, that's a bug. It should work more like what Kevin describes above with

    Can someone recreate that same process with only the Paypal Solo gateway enabled?


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.