The site was fast

Hello
The site was fast browsing and no problems browsing the website services but after installing plugins became slow starter, please fix the problems and adjust settings
I want to continue and extend the subscription but with these problems don't think so
Please repair the damage and bring to life the site
Thank you

  • Sajid

    Hello ibrahim,
    Hope you are doing good today :slight_smile:

    I see the speed of your site is really terrible but I don't think it is just because of the plugins. That is because most of the plugins you installed from us for administration purpose only like Hummingbird, WP Smush plugins. To make sure its not our plugin, I deactivate all WPMU DEV plugins but the site is still taking upto 30 seconds to load (I activated these plugins back for you).

    I see the perfomance report and run it one more time for latest results. It seems the main issues are GZIP Compression and server response time.

    Please enable GZIP on your site to reduce the size of the page content. I see its enabled for HTML it is not working properly.

    The message suggests that the "mod_deflate" module may not be enabled but that may not always be the case.

    Please double-check your server for following issues as well:
    - check if there's a Varnish cache running on server (or any other server-side caching solution) and make sure to purge/empty it

    - make sure that PHP is configured to support zlib library and that zlib output support is enabled; there's a php.ini setting for this that should be set to "on":
    zlib.output_compression = On
    In case it's set to "off" you will want to change it to "on" and restart Apache

    - there's also a slight chance that not all required MIME types are set to be handled by "mod_deflate" module; it should support at least "text/html", "text/javascript" and "text/css"

    You may need to contact your hosting provider for these steps but I hope it'll fix the issue.

    Secondly, most important issue is server response time. Its taking 5.6 seconds to respond, that is a lot.

    You can improve the server response time by following methods as mentioned in the performance repot too.

    Basic Recommendation, that you can do yourself.

    1. Install and configure a full page caching plugin like WP Super Cache or Batcache. This can substantially improve your response time for logged out visitors and search engine bots.

    2. Usually your installed WordPress plugins have the greatest impact on your page generation time. Some are horribly inefficient, and some are just resource intensive. Test the performance impact of your plugins using the P3 plugin, then remove the worst offenders, or replace them with a suitable alternative.

    ADVANCED RECOMMENDATIONS:

    1. Confirm with your host that you are running at least PHP 5.5 and OPcache is enabled in your site's PHP configuration.

    2. Install and configure an object caching plugin on your site (Redis or Memcached recommended).

    3. Ask your host if they support PHP7 or HHVM (Facebook uses HHVM, that's why it loads really fast) to help your PHP execute faster.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support