The Smushing of my photo library stalls, does not finish

Hi

I'm smushing my library but it's stalling, it's doesn't finish the smushing.
You have access to my blog.
Look forward to hear from you.

Best

    Adam Czajczyk

    Hello Kamel,

    I hope you're fine today!

    I accessed and checked your site and I found that there's a lot of images there that are actually... not there

    Here's what I mean:

    - access your site
    - go to "Media -> Library" page in its dashboard
    - switch it to "list" view
    - then go to the last page (I think it's page 701 currently)

    You will see that there are images listed that don't even show thumbnails. When you try to edit such an image, it also doesn't load.

    That means that these images were removed from server but not from WordPress; most likely they were simply deleted from the server. The issue here is that WP Smush Pro reads WordPress database and tries to fetch these images.

    Usually it would just skip them but since there's over 14,000 of images registered in a database in total, it takes time and may cause the script to time out at some point. If you keep enabling bulk smushing it will eventually go to the "end" but will still be showing that a number of images needs smushing.

    The solution here would be to clean up Media Library a bit. This can be done in two ways:

    - either re-upload those missing images in their original locations via FTP; you will need to make sure that they are uploaded to these exact folder where they were before and use exactly the same name

    - or use "Delete Permanently" link in Media Library for each of them to remove them from the database

    Once that cleaning up is completed you and you run "bulk smushing" again, plugin should be able to complete the process and update data to reflect the reality.

    Best regards,
    Adam

    Adam Czajczyk

    Hello Kamel!

    Thank you for your replay!

    What I suggested is a solution for the WP Smush Pro plugin not being able to smush all the images and hanging up at some point. It should help with this.

    As for "washed out" images I believe we are talking about that in your other thread here:

    https://premium.wpmudev.org/forums/topic/the-smushing-doesnt-smush-my-pics-anymore

    As I already responded you there, let's keep it going in that other thread if it comes to image quality and only get back here if cleaning up the Media Library doesn't help with WP Smush Pro "hanging up"

    Best regards,
    Adam