The Stripe Token was not generated correctly. Please try again

Hi, I have looked at other topics with similar title and have not been able to find a solution to this issue. Hopefully someone there recognizes the issue and has a quick fix.

This is happening on 2 separate sites, both using same theme and marketpress, It is still on v2.9.xx as there has been major problems each time we have attempted to update marketpress, I have done previous posts about it.

The error: The Stripe Token was not generated correctly. Please try again comes up when trying to do a live purchase.

I can confirm the API keys are the live keys and not the test ones. 2 accounts have been created so there is different API keys for each site.

the 2 sites are:
http://www.ultimatesportsmemorabilia.com.au
http://www.licensedsportsmemorabilia.com.au

Following is from a support ticket sent to stripe earlier today:

Thanks for getting in touch, and I hope that you're keeping well. The most recent error you saw has to do with how our API works. I'm going to look a little further into this on my end to see if there's anything we can do to help.

However, please bear in mind that seeing as you're using MarketPress, they should be able to help you out with this, and I'd recommend getting in touch with them.

While I'm looking further into this on my end, feel free to send any other issues you might have my way.

Hope you can help with this.

I'll grant support access for you to take a further look.

  • Predrag Dubajic
    • Support

    Hi Karen,

    Hope you're doing well today :slight_smile:

    Sorry to hear you're having issues with the MP 3.x versions, we did release 3.0.0.8 version recently that comes with number of fixes so could you check if the issues you reported in other threads are still happening after that?

    About the stripe issue, can you tell me if this is only happening with live credentials or does it happen with test ones as well?

    Also, if you go to https://dashboard.stripe.com/account/apikeys you should see API Version on top of the popup window, can you tell us what's the date for your API key and if you have recently updated to that version?

    Best regards,
    Predrag

  • Karen
    • Design Lord, Child of Thor

    in test mode, i got this message
    There was an error processing your card: "Invalid API Key provided: " **_****_********************cjY0". This key contains at least one space. Please delete the spaces and try again. If you have any questions, we can help at https://support.stripe.com/.". Please go back and try again.

    2016-03-07 (latest) is date at top of API Page.

    I'm very reluctant to upgrade right now, as I feel it is a conflict with the iThemes theme.

    Does this info help to find a solution?

  • Karen
    • Design Lord, Child of Thor

    I have fixed the issue for anyone after me. I was my mistake.
    I regenerated the API Keys and pasted them in correctly. There was a space at the start of the field in marketpress which threw up the error even though I'm sure I copied just the content of the API from Stripe.
    Anyway lesson learned, hope this helps future users.

  • Milan
    • WordPress Wizard

    Hey Karen,

    Thanks for explaining us what you did to resolve your issue. Its quite common mistake and this will surely help our community members.

    One quick advise for you here is to update your MarketPress. :slight_smile:

    Now as this thread is reached to its conclusion, I am marking this one as resolved. Karen, you do not need to reply us back here any more. :slight_smile:

    In this, case if this issue comes up again, I suggest you to open new thread. Thanks for being with us. :slight_smile:
    Cheers,
    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.