THE UPDATE BUTTON IS NOT ENABLED

Whenever I want to edit an event page, the update button is not enabled. I could not save any edited page. Any clue????

  • Rupok

    Hi Karen,

    I tried to regenerate this on my test site but I could not. I can see the Update button working fine.

    So I think this is your site specific issue. Can you please do a plugin conflict test just to make sure no other plugin is causing this? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Can you also try activating any default WordPress theme? That will make sure your currently active theme is not creating any conflict.

    Can you check your browser console and let us know if there is any error being shown?

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day. Cheers!
    Rupok

  • Rupok

    Hi Karen,

    Thanks for granting Support Access. I logged in, went to DCAD site Dashboard, tried to edit an event from the back-end, the "Update" button worked absolutely fine. Please check the attached screenshot for reference.


    Then I viewed that event in front-end, clicked on "Edit Event" link on front-end, and tried to update that event from front-end. I was also successful this time. Event was updated without any issue. Please check the attached screenshot for reference.

    So I could not regenerate the issue on your site. I asked my colleague Nithin to test, he could not see the issue on your site. Update went fine for him too.

    Can you please try clearing cache and cookies from your browser and try again? Can you please try from another browser and check if the issue is still there? Can you please try from another network?

    Please let us know if you still face this issue from different browsers, even from different network. I'll ask more people to try to regenerate this. We can help as soon as we can regenerate. Please let us know your findings. I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Karen

    Hi Rupok,

    I tried what you suggested except I am not on another network. I also tried to do remote access to my office to see if this helps. It appears it does not make any difference. Maybe I should do step by step to see if I am doing anything wrong. I'll still check in my office tomorrow afternoon when I am not busy. I am volunteering to do the web work for a very small non-profit organization for no charge.

    I select Events from the Dashboard left navigation menu.
    I want to edit the 35 years Gala event.
    Whenever I try to add something or edit. I kept seeing "autosave" warning at the top. I tried to restore or just ignore both ways.

    See the first PDF shows the UPDATE button is not enabled.
    After I inserted an image of leaf or just typing a text, the button is still not enabled.

    Any idea? If not, maybe I should do the clean uninstall of Events and try again. Could you list the tables which Events depends on? I sincerely hope you will catch something that I overlooked.

    See the attached 2 PDF files.

    Crossing my fingers and toes.
    Thanks you in advance, Karen

  • Karen

    One more note: I tried WP-DEBUG and set this to true for the first time.
    I noticed there is a warning message saying
    "Notice: The called constructor method for WP_Widget in AgmMapsWidget is deprecated since version 4.3.0! Use
    __construct()
    instead. in /xxx/xxx/xxx/wp/wp-includes/functions.php on line 3767

    Does it tell you something? Is this related to Google Maps?

    Feel hopeless, Karen

    • Karen

      In case, if you feel annoyed seeing the warning message.
      "Notice: The called constructor method for WP_Widget in AgmMapsWidget is deprecated since version 4.3.0! Use
      __construct()
      instead. in /xxx/xxx/xxx/wp/wp-includes/functions.php on line 3767

      I was able to stop this.

      In class-agm-maps-widget.php (WPMUDEV google map), I changed

      from parent::WP_Widget( false, $name = 'Google Maps Widget' ); to
      parent::__construct(false, $name = 'Google Maps Widget' ); on line 8

      The annoying message went away nicely. :innocent:

  • Ash

    Hello Karen

    Please check now. The issue was your start date was larger than your end date. Your start date was 1st October and end date was 19th September. I have changed the start date to 1st September and I could update. You can modify the events date now, but make sure end date and time is always larger than the start date.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.