The web calendar is running very slow

The web calendar is running very slow and sometimes not working. Select service and no problem, but then selecting supplier gets stuck.

  • Gerardo

    Hello,

    php:
    11-Dec-2015 02:56:17 UTC] Error Query execution was interrupted de la base de datos de WordPress para la consulta SELECT * FROM wp_app_appointments WHERE service=17 AND worker=14 AND (status='pending' OR status='paid' OR status='confirmed' OR status='reserved' OR status='completed') AND WEEKOFYEAR(start)=52 realizada por require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/ultrasonic/page.php'), the_content, apply_filters('the_content'), call_user_func_array, do_shortcode, preg_replace_callback, do_shortcode_tag, call_user_func, App_Shortcode_MonthlySchedule->process_shortcode, Appointments->get_monthly_calendar, Appointments->get_timetable, Appointments->is_busy, Appointments->get_reserve_apps_by_worker, Appointments->get_reserve_apps
    [11-Dec-2015 14:27:34 UTC] Error Server shutdown in progress de la base de datos de WordPress para la consulta SELECT * FROM wp_app_appointments WHERE service=2 AND worker=0 AND (status='pending' OR status='paid' OR status='confirmed' OR status='reserved' OR status='completed') AND WEEKOFYEAR(start)=53 realizada por require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/ultrasonic/page.php'), the_content, apply_filters('the_content'), call_user_func_array, do_shortcode, preg_replace_callback, do_shortcode_tag, call_user_func, App_Shortcode_MonthlySchedule->process_shortcode, Appointments->get_monthly_calendar, Appointments->get_timetable, Appointments->is_busy, Appointments->get_reserve_apps
    [11-Dec-2015 18:30:40 UTC] Error Lost connection to MySQL server during query de la base de datos de WordPress para la consulta SELECT * FROM wp_app_appointments WHERE service=5 AND worker=2 AND (status='pending' OR status='paid' OR status='confirmed' OR status='reserved' OR status='completed') AND WEEKOFYEAR(start)=53 realizada por require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/ultrasonic/page.php'), the_content, apply_filters('the_content'), call_user_func_array, do_shortcode, preg_replace_callback, do_shortcode_tag, call_user_func, App_Shortcode_MonthlySchedule->process_shortcode, Appointments->get_monthly_calendar, Appointments->get_timetable, Appointments->is_service_possible, Appointments->is_busy, Appointments->get_reserve_apps_by_worker, Appointments->get_reserve_apps
    [11-Dec-2015 18:30:40 UTC] Error Lost connection to MySQL server during query de la base de datos de WordPress para la consulta SELECT * FROM wp_app_appointments WHERE service=19 AND worker=8 AND (status='pending' OR status='paid' OR status='confirmed' OR status='reserved' OR status='completed') AND WEEKOFYEAR(start)=52 realizada por require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/ultrasonic/page.php'), the_content, apply_filters('the_content'), call_user_func_array, do_shortcode, preg_replace_callback, do_shortcode_tag, call_user_func, App_Shortcode_MonthlySchedule->process_shortcode, Appointments->get_monthly_calendar, Appointments->get_timetable, Appointments->is_busy, Appointments->get_reserve_apps_by_worker, Appointments->get_reserve_apps
    [11-Dec-2015 18:30:40 UTC] Error Lost connection to MySQL server during query de la base de datos de WordPress para la consulta SELECT * FROM wp_app_appointments WHERE service=6 AND worker=5 AND (status='pending' OR status='paid' OR status='confirmed' OR status='reserved' OR status='completed') AND WEEKOFYEAR(start)=52 realizada por require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/ultrasonic/page.php'), the_content, apply_filters('the_content'), call_user_func_array, do_shortcode, preg_replace_callback, do_shortcode_tag, call_user_func, App_Shortcode_MonthlySchedule->process_shortcode, Appointments->get_monthly_calendar, Appointments->get_timetable, Appointments->is_busy, Appointments->get_reserve_apps_by_worker, Appointments->get_reserve_apps
    [11-Dec-2015 19:24:28 UTC] Error Server shutdown in progress de la base de datos de WordPress para la consulta SELECT * FROM wp_app_appointments WHERE service=2 AND worker=6 AND (status='pending' OR status='paid' OR status='confirmed' OR status='reserved' OR status='completed') AND WEEKOFYEAR(start)=51 realizada por require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/ultrasonic/page.php'), the_content, apply_filters('the_content'), call_user_func_array, do_shortcode, preg_replace_callback, do_shortcode_tag, call_user_func, App_Shortcode_MonthlySchedule->process_shortcode, Appointments->get_monthly_calendar, Appointments->get_timetable, Appointments->is_busy, Appointments->get_reserve_apps_by_worker, Appointments->get_reserve_apps

    the access its ready.

    best regards

  • Michael

    I recently migrated my website over to https and I thought this was what was causing my problem. Now I have read a few posts on the forum I realise it is not the case. There is definitely an issue with 1.5.4 which is causing huge delay in loading pages containing calendar info. I have had my website timing out and returning a 500 error when someone tries to book an appointment, I have had appointment confirmations timing out and I have had admin confirmation emails not being sent. My gmex and google pagespeed scores were showing a server response time of over 10 seconds to open a page containing a calendar.

    I've just rolled back to 1.5.2 and everything is good again, pages load quickly and everything seems to work as it has done for the last year or so I've been using this plugin.

    Please take a look at the modified code between 1.5.2 and 1.5.4 as I've seen numerous threads where support suggest it may be the hosting package the end user is running etc but user responses suggest the hosting is unchanged but performance is seriously reduced. This is certainly the case for me, I have actually upgraded my web server but with 1.5.4 the performance was awful compared to previous versions.

  • Luís

    @GerardoHi @Gerardo and @Michael,

    Honestly, I can't reproduce the issue in my install. Besides that I tested the performance and again, I don't see any differences in the page loading.

    I flagged the SLS team (our code experts :slight_smile: ) to investigate further and get their valuable feedback.

    Since this team deals with more advanced threads it may take them longer to reply.

    @Gerardo, if possible, can you send the FTP details from one of your fresh installs where you referred that are getting the issue.

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.