The website has been down a few times

I have received message and I have seen my website down a few times. I have already called my host and they told that they were too many requests log shows errors like the following:

Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
FastCGI: An error happend on Fastcgi processing, fallback to CGI

I have already taken off jetpack which was used for atomatic post to facebook and linkedin.

  • Patrick Freitas

    Hi Hannah,

    Sorry to hear that you are having issue.

    In most of the cases this error has to do with .htaccess, However after a closer look your file it seems to be ok, I would suggest you to run a plugin test.

    So, would you mind please run a conflict test?

    Remember, is important that you run this test in a staging site, if you can’t do it you must create a full backup.

    Firstly we could enable the WordPress debug in the wp-config.php,
    Going to WordPress root folder, edit the wp-config.php file and adding above /* That's all, stop editing! Happy blogging. */ comment this part of code

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    You can find more information here : https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/
    This will create more logs that you can we can check after.

    Please deactivate all the plugins and check if the problem gone. If so, then enable all plugins one by one and find which one is creating the issue.

    If you still having this issue, could you do a theme test, much the same as the plugin test, but now you’re testing themes!
    Activate one of the default WordPress themes, like Twenty Sixteen or Twenty Seventeen.

    Here you will find more information: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    Let us know the results that you get,
    Best Regards,
    Patrick Freitas

  • splaquet

    patrick is correct, on how you'd diagnose a scripting/plugin error or issues caused by the site itself.

    *Pretty much everything beyond this line will assume that you're on a server using a CloudLinux OS, which might not necessarily be the case... but is a safe assumption these days for shared hosting environments*

    As a web host, I'd actually suggest that you first look at your hosting environment. If you use one of the "popular" goto hosts, they're more frequently using CloudLinux as their server OS. With that, you're usually placed within their CageFS environment and you have control over your resources using the PHP Selector tool, in cPanel.

    I often find this next case is often the issue that my new clients have, specifically if they were using GoDaddy (easiest example). They'll usually be "throttled down" by default, not knowing how to update their preferences.

    If you head to cPanel -> PHP Selector, you'll see:
    - where you can easily adjust your PHP version (7.2 is very compatible these days and is *very* fast compared to 5.6, the default/native)
    - if you click on the next tab "Switch to PHP Extensions", you'll see several options that you can tweak and upgrade on your own. make sure that your RAM is on the highest option that you can set to. I've seen as little as 32mb on GoDaddy, where you can bump it up to 256mb in Selector. 256mb is the recommended ram for WordPress.

    So, although those options might not be a cure all for you, they should make things better.

    To jump back into your question... so, if you hit the CPU limit, RAM limit, MySQL limit, etc, CloudLinux will "throttle" your account. That throttling will usually take your website down for a few seconds to a few minutes.

    You can see your actual usage on the right side of your main cPanel interface.

  • splaquet

    well,

    1) if you're maxing out your CPU, the host is most likely throttling your account. so that's probably taking it down for short bursts

    2) you have a 30 (maybe 50) concurrent connection limit to your MySQL DB. that equals about 30 users (user can be a visitor, admins, editors, and i'm also assuming that'd include remote scheduled cron requests to third parties, like WPMU). so, if you have multiple websites installed on that account, or even one with any amount of traffic, you're most likely hitting those limits as well.

    3) IMO, no need to look any further. those 2 items are most likely where your bottle neck is. using a CDN might help you out a little bit, but honestly, using a host that provides more resources is probably your best solution.

    I'm not a "pro", but from what I can see... the provider seems to present themselves as though they're giving you ALL THIS AND MORE!!! ...but the fine print is telling me that even though you have a dedicated MySQL server with all of amazing performance, only 30 users at a time really kinda kills any added bonus.

    my .02

  • splaquet

    There's a million possibilities on what those could be from. I also didn't notice a limitation on your outbound connections when I looked at your hosting package specs. Only a limit on database connections.

    I honestly can't really provide a quick and easy answer for you, without having access to any and all.

    My quick answer would be that I'd provide you hosting, comparable to what they're providing, for less.

    If you don't have access to logs and other info in your control panel, you'd have to find a connection monitoring extension for WP. In my honest opinion, if your provider can't easily provide that info, consider a different hosting company.

  • Patrick Freitas

    Hi Hannah,

    I can see in the attached file that your outbound connections had a relevant increased. I agree with splaquet it can be caused by some bad web hosting service.
    Some web hosting does not inform the limitation of connections but they do it, if you don’t mind, you could check this information with the host provider.
    However I had a closer look in your debug log, which is located at wp-content folder I can see that many times you are getting error .

    [22-May-2018 20:05:39 UTC] PHP Notice: Trying to get property of non-object in /home/israelvalk/www/wp-includes/class-wp-query.php on line 3871

    I made a quickly research and this functions seems to be deprecated since Avada 5.2.0, some other people had the performance problem in their websites.

    As the kd_mfi_get_featured_image_id function has been deprecated I would recommend use fusion_get_featured_image_id instead and see if this does fix the problem.

    If It doesn’t I keep thinking that a plugin/theme test is important, some of plugin depend of its functionality, not all functions of them are fired up continuously and the performance issue would be caused by certain action from one of the plugin, woudn’t you mind also please check other different facts as a outdate plugin or a non PHP 7 compatible plugin.

    You can also install our defender plugin, it will check if your website has any vulnerability:
    https://premium.wpmudev.org/project/wp-defender/

    Have a nice day
    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.