The 'Wordpress Membership' plugin is not showing our 'index.php' after enabled

Hello there WPMU,

My website address is (www.affiliatemade.tv) and I've disable my 'coming soon' plugin so you can see it.
We've installed and configured the 'Wordpress Membership Premium' plugin on an install of 'Wordpress 3.0.4', according to the installation documentation you provide on your website.

I've created a 'stranger' level & a 'member level', along with a free 'member subscription', and I have activated my levels and subscription. I've modified my options according to your install documentation and I'm having a issue.

My issue is this:
When I 'enable' the membership plugin it somehow looses my index.php file entirely (aka. my homepage). The other rules that I've applied with this plugin have worked, but this is one problem that I can't figure out. I've attached two screenshots with this post so you can see what I'm seeing...the second one is with the membership plugin 'disabled' (how it should look) & the first one is with it 'enabled'.

I look forward to solving this issue, thanks in advance for the help!
Chais

  • controlyours
    • Site Builder, Child of Zeus

    Hey there Barry,

    I've attached three screenshots (my "Strangers" membership level, my core 'subscription' that doesn't really apply, and my 'options')...they're a little grainy to keep them under the file size limit...sorry.

    Thanks for assisting me,
    Chais

  • controlyours
    • Site Builder, Child of Zeus

    I have some new insight on this problem...
    If I check the box that says "Membership Administration...This user has access to administer the Membership system." (which is inside the 'Edit User' section of Wordpress), this user can see the index.php page. No one else can however, even if they're a straight up Wordpress Admin.

    Any helpful thoughts yet?

    Thanks again and I look forward to hearing back from you guys,
    Chais

  • Mason
    • DEV MAN’s Sidekick

    Extremely odd. I haven't seen this happen before. I'll ask Barry to drop by and take another look. Your rules and settings look alright to me.

    I'm wondering if it's something with this theme specifically that's causing the issue. We'll take a look. Let us know if you discover anything further.

    Thanks!

  • controlyours
    • Site Builder, Child of Zeus

    Mason,

    Thank you very much for the response.
    I doubt that it could be a theme issue and I really appreciate any and all help you can provide for this one...I just don't know this plugin well enough.

    If you guys need a user/pass with admin writes to mess with settings, just give me an email address and I'll send the login credentials your way.

    Thanks again,
    Chais

  • controlyours
    • Site Builder, Child of Zeus

    It appears to work fine on another theme (even though its hard to tell because we've really customized the theme we're using's 'index.php')...

    Would it help if you had the theme we're using...or what do you recommend next?

    Thanks again,
    Chais

  • controlyours
    • Site Builder, Child of Zeus

    Another Thought...

    I noticed that the rules seem to apply when say a particular page is allowed for a member - the content of that page is visible however...if some of the content on that page is actually in the page template - the content is hidden to the user. I have a feeling that's why the index.php file isn't working correctly - since so much of the content on this page is in the template - not an actual "page" managed by Wordpress. Does any of this ring a bell?

    For example: I have a page where I've added some text using the WYSIWYG editor in Wordpress. This page is viewable by a non-member using the plugin. This page is also using a page template via Wordpress. In this page template I have some other content - however this content is not viewable to the non-user.

    Any thoughts on this?

  • controlyours
    • Site Builder, Child of Zeus

    Nevermind guys, we figured it out.

    If anyone's going to use the 'CleanCut' theme (and you're not using the featured area), make sure that you comment that section out or you will rip out all of your hair wondering why things won't work.

    Thanks for the help

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.