The X to close the box continues to pop up after closed.

Is this Pop Up! or Popover? It's showing up as Popover in my plugins, but Pop Up here?

That's not my main question. :slight_smile:

For some reason my popup to subscribe is still showing the X to close the popup after it's been closed. This is nice for me as an admin, because it helps me check to see how it's working. But probably not so nice for visitors to the site. You can check it out at http://escapeamericanow.info/.

I have it set to open on exit. That works great. Then, if the person closes it, that works too. It seems to be fine until they revisit. Then, it triggers when they go to exit, revealing the X in the center of the page.

I doubt if this really bothers anyone. But it has been noticed, and it's obviously not as clean as we'd like.

Thanks,
Joe

  • Alexander
    • DEV MAN’s Mascot

    Hi @Nitrous Cloud,

    As for the plugin name, I'm sorry for any confusion here. It's "Pop Up!" but was formerly Popovers, I'm not quite sure why the name hasn't change in the plugin, but I'll mention it to @Vladislav who has taken over development for this plugin.

    I've not seen this issue before, but it may be a plugin conflict. Can you test a few things for me to see if it makes a difference?

    Try with cacheing disabled.

    Try with the TwentyThirteen theme.

    From Pop Up Settings, try using a different loading method.

    Let me know what you find out here.

    Best regards,

  • Nitrous Cloud
    • The Crimson Coder

    Oh, I think I see what you're talking about - footer, external... I tried all three. No changes.

    Twenty thirteen didn't help.

    Turning off the WP Super Cache changed it, but didn't really help. For whatever reason, it kept popping back up with each exit move... the whole form rather than just the X.

    Thanks
    Joe

  • Alexander
    • DEV MAN’s Mascot

    Did you do all the testing with cacheing disabled? Or did you try that last? I think cacheing is the main cause at the moment.

    Can you confirm that you tried the above options with cacheing turned off? It's working ok for me in TwentyThirteen, so I'm not sure why this wouldn't work the same for you.

    The next thing we would need to try is plugin conflict testing.

    You can do this by deactivating all your plugins. After this, test the issue as see if anything is different. If it's working, we know it's a plugin conflict. Then start reactivating your plugins and testing as you go along, once it stops working you'll be able to know which plugin is causing a conflict. Once a conflict is identified, we can look into a specific solution for it.

    Best regards,

  • Alexander
    • DEV MAN’s Mascot

    Hi @Nitrous Cloud,

    I'm sorry for the delay here. I've looked into this, and I'm still unsure what would cause this. Can you try the new version we released yesterday? Let me know if this update makes a difference. Also, try the "footer" loading method, as it is least dependent on javascript.

  • Nitrous Cloud
    • The Crimson Coder

    Thanks Alexander,

    I've updated and changed it to footer. It's still behaving the same. When I turn off the ad management plugin, it seems to be working. I can't tell if it's working perfectly, but it's not giving me the X any longer.

    The developer of datafeedr said he doesn't have access to the plugin. You can see his response in the thread I linked above.

    I could try another plugin, but I like sticking with you guys for a lot of reason. And I would have to pay for the other one I'd use, since it integrates with a couple of other plugins I use.

    Any ideas?

    Thanks,
    Joe

  • Alexander
    • DEV MAN’s Mascot

    Hey @Nitrous Cloud,

    Are you still having some issues here? I'm very sorry about missing your last post. If you'd like, I can login and do some troubleshooting. Would you mind sending WordPress + FTP info? If this is ok, just use the contact form: https://premium.wpmudev.org/contact/
    - Choose "I have a different question"
    - Include my name in the subject "Alexander Rohmann"
    - Include a link back to this thread
    - Include any relevant login information

    Best regards,

  • Nitrous Cloud
    • The Crimson Coder

    Thanks Alexander,

    I haven't noticed the issue lately. Maybe one of the updates fixed it. Also, I removed a couple of plugins that seemed to be conflicting with others on the site, so maybe that fixed it. Honestly, this one rolled of my radar too. :slight_smile: I'll shoot you a note if I see anything pop up again though (pun intended).

    Kind regards,
    Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.