Theme settings don't take effect on subsites

Hi guys,

Silly question - I'm probably missing something obv since it's Sunday, but my theme settings don't take effect on subsites (same theme enabled on all).

It's not a caching issue. My host doesn't know. Is it rewrite issue? Not sure, but please let me know if there is an easy fix or you want more info. Thanks!

Derek

  • Adam Czajczyk
    • Support Gorilla

    Hello Derek,

    I hope you're well today and thank you for your question!

    Don't worry please, you are not missing anything even though it's Sunday :slight_smile:

    It's supposed to work this way. Settings applied to the theme on any of the sites in Multisite WP should not affect any other sites. That's the way it's designed to work because admins of sites should be able to set/configure themes the way they want.

    The difference is though if you make a change to theme files but that's, well, "what it is" - changing a theme itself :slight_smile:

    Have a great Sunday!
    Adam

  • Derek
    • Site Builder, Child of Zeus

    Haha. Hey Adam! Good to talk to you again.

    Thanks for the reply. It's actually more basic than that - I'm actually just trying to get the theme settings to take effect on a single subsite (i'm not worried about it effecting any other sites). I'm very familiar with the theme but if I change any of the basic theme options (menu, css, etc.) it will save (on the the theme settings page) but won't render on live sub site. It's just bizarre. I've tested it on 5 different subsites now.

    Sorry for not being more clear earlier :slight_smile:

  • Adam Czajczyk
    • Support Gorilla

    Hello Derek!

    That's a different story then, it seems I misunderstood you at first. Clearly, Sunday affects me more than you :slight_smile:

    Having that said, I'd love to check you site. Could you grant me a support access to it using our WPMU DEV Dashboard plugin and also point me to the subsite in question (and let me know about which settings are affected)?

    I'll test it and hopefully find a reason and a solution. Here's a guide on granting access:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam

  • Derek
    • Site Builder, Child of Zeus

    OK access granted :slight_smile:

    the subsite we are trying to edit is 'build1". If you jump up to theme options > top bar & header on top admin bar, none of the saved settings take effect. It doesn't work on all the subsites actually. I hope it's not a simple hosting issue, but they claim it's not.

    Thanks a ton for your help! You're awesome!

  • Adam Czajczyk
    • Support Gorilla

    Hello Derek!

    Thanks for this information and granting access.

    Unfortunately, the site doesn't let me in. Instead of accessing the dashboard I'm getting redirected to the login form which in turn gives me this sweet message:

    "You do not currently have a Shield user session.
    Please login again."

    I suppose there's some kind of additional security layer so could you e.g. temporarily switch it off or somehow add an exception for me? If it's IP based then I'd suggest switching it off for now as 1) there's no point in giving you my IP as it may automatically change any moment (I'm not using fixed one) 2) my colleagues are from all over the world so they may be using different IPs :slight_smile:

    That being said, please take a look at site's settings and see if you could allow me to access the site.

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Derek!

    Thanks for taking care of it.

    If you visit the site now you'll notice that it looks a bit different after I made changes (though you may need to clear you browser cache first). I left it this way so you could see this.

    The issue here is actually cache. The solution: before you make any changes to the theme settings, please go to the "Super Cacher" menu page in that site's dashboard and disable the "Memcached" cache, then "Purge SG Cache" and make your changes.

    They should be applied. If there's still no efect, purge SG cache again after changes are made. Once you're done with configuration, you may enable "Memcached" again.

    I hope that helps!

    Best regards,
    Adam

  • Derek
    • Site Builder, Child of Zeus

    You got to be kidding me! Really? Thanks for figuring that out. Wow.

    Ok, one last question - so to see updates when working, best practice is prob to disable 'memcached' and regularly purge SG cache from top admin bar?

    thanks for this Adam. I should have seen this one coming.

    Derek

  • Predrag Dubajic
    • Support

    Hi Derek,

    It's always a good idea to have caching disabled while the site is still under development, this will allow you to see the changes immediately.

    As for purging cache, I believe this won't be necessary if you disable caching.
    After you have disabled it there will still be some cached file saved so purging cache will clear those and since it's disabled it shouldn't create new one.

    Best regards,
    Predrag

  • Derek
    • Site Builder, Child of Zeus

    Hi Predrag,

    Thanks for the response and I hope you're having a great day!

    For some reason with the muli site install I still can't get basic theme settings to display, even after disabling all the above. Works fine on single WP installs but all this caching nonsense is killing our dev time on these sub sites.

    I'm not sure how Adam was able to make changes on his end. I'm starting to think I may have a hardware or rather hosting issue of some kind.

    Thanks again for your help!
    Derek

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.