Themes don't work on my MultiSite sites

Themes don't work on my MultiSite sites.
The theme works only for the primary site.
Whether I network activate or enable themes, the sites show only as HTML.
I tried editing my .htaccess file with:

Subfolder Example

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

I can even have a blank .htaccess file and WP runs normally.
I changed permissions on the wp-content folder for users to FULL CONTROL.
The WP site is running on a local server.

Nothing is working!

Please help!

  • Justin

    Also, when I go to My Sites -> Network Admin -> Sites

    When I click on Dashboard for a site I get:

    The ##.###.##.### page isn't working
    ##.###.##.### redirected you too many times.
    ERR_TOO_MANY_REDIRECTS

    But, when I click Dashboard for the primary site it works.
    _______________________________________________________________________________________________

    My installation was different. Instead of replacing the .htaccesscode, I was prompted to replace my web.config code with:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
            <rewrite>
                <rules>
                    <rule name="WordPress Rule 1" stopProcessing="true">
                        <match url="^index\.php$" ignoreCase="false" />
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 2" stopProcessing="true">
                        <match url="^webtemplate5/([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
                        <action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
                    </rule>
                    <rule name="WordPress Rule 3" stopProcessing="true">
                        <match url="^" ignoreCase="false" />
                        <conditions logicalGrouping="MatchAny">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
                        </conditions>
                        <action type="None" />
                    </rule>
                    <rule name="WordPress Rule 4" stopProcessing="true">
                        <match url="^webtemplate5/([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)" ignoreCase="false" />
                        <action type="Rewrite" url="webtemplate5/C:/inetpub/wwwroot/WebTemplate5/{R:1}" />
                    </rule>
                    <rule name="WordPress Rule 5" stopProcessing="true">
                        <match url="^webtemplate5/([_0-9a-zA-Z-]+/)?([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
                        <action type="Rewrite" url="webtemplate5/C:/inetpub/wwwroot/WebTemplate5/{R:2}" />
                    </rule>
                    <rule name="WordPress Rule 6" stopProcessing="true">
                        <match url="." ignoreCase="false" />
                        <action type="Rewrite" url="index.php" />
                    </rule>
                </rules>
            </rewrite>
        </system.webServer>
    </configuration>
  • Rupok

    Hi Justin

    Hope you had a wonderful day.

    I think you already have a post regarding this issue: https://premium.wpmudev.org/forums/topic/multisite-sub-directory-themes-not-working

    Can you please open one ticket per issue so it becomes easier for both you and us to track the issue and find the solution? And as this ticket has valuable information regarding your problem, do you want me to close the other thread and continue all updates here in this thread?

    I can even have a blank .htaccess file and WP runs normally

    WordPress will run smoothly even if you don't have a .htaccess file at all. It will create one for you when necessary.

    I changed permissions on the wp-content folder for users to FULL CONTROL

    Can you please change permission settings to what I've said here: https://premium.wpmudev.org/forums/topic/multisite-sub-directory-themes-not-working#post-1068678 ? Try to set this permission for all files and folders in your web root directory, not only the wp-content folder.

    The WP site is running on a local server

    Which one is your local server running? IIS or apache or nginx?

    My installation was different. Instead of replacing the .htaccesscode, I was prompted to replace my web.config code with

    Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day. Cheers!

  • Rupok

    Hi Justin

    Hope you had a wonderful day.

    Well, I might not be a very expert of Windows Server, but I can definitely try. I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day. Cheers!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.