Themes not working

Hi, I updated this thread earlier (https://premium.wpmudev.org/forums/topic/product-theme-not-loading-properly) but later realised it's an old thread so I'm not sure if it's closed. I have twentyten and twentyeleven and a child theme of twentyeleven installed on wp3.2.1 all of which work as expected. I have tried installing Business Services and Product but both templates show nothing on the homepage of my website - Product prompts me to edit some widgets, Business Services doesn't. I can edit the theme options in both themes but they make no difference to the homepage. If I search for a page that doesn't exist I get a themed 404, but otherwise nothing. I gather this is something you've seen before, so wondered if you had a fix please? Thanks.

  • DavidM
    • DEV MAN’s Mascot

    Hi mrsimnok,

    Sorry you're experiencing some trouble using the theme. I've just tested the Business Services feature again on a test site and couldn't see any issues there.

    We had some recent updates to the download files here. Could you try downloading a fresh copy and install that to be sure we're on the same page?

    If it's still having issues, could you check your error logs to see what they say?

    Just to check too, have you tried deactivating any other plugins? If not, could you give that a try to see if there's a conflict there?

    Also, could we maybe get a link to the site to see if we can spot anything?

    Thanks,
    David

  • mrsimnok
    • WPMU DEV Initiate

    Thanks for the response David. Here's what I have done:

    1. Deactivated all plugins and tested - no change. I have left them deactivated so you can see.
    2. Deleted the themes, downloaded new copies of Product and Business Services and installed those - no change. I have left Product activated so you can see.
    3. Checked my error logs - no errors there at all.

    It looks to me like only the sidebar is loading in both templates. Here's a link to my site: http://itprojecttools.com/

    Many thanks for your help,
    Simon.

  • DavidM
    • DEV MAN’s Mascot

    Hi Simon,

    Thanks for providing the link, definitely helps here. I took a screenshot of your page source and have a attached it as follows:

    That shadow-spacer div you're seeing is not generated by the theme. Something else is loading that in there. Finding out what's loading that should help to sort this for you.

    Also, when I first visited the url, it had '?doing_wp_cron' tacked onto the end. There's a bit about that at the following from wordpress.org.
    http://wordpress.org/support/topic/doing_wp_cron?replies=11

    -David

  • mrsimnok
    • WPMU DEV Initiate

    Hi David,
    Thank you - that's really useful. I couldn't work out what would be loading the shadow-spacer div if all of my plugins were disabled (they are) and only the theme is activated, so I googled it and it led me back to another WPMU Dev posting:
    https://premium.wpmudev.org/forums/topic/get-rid-of-buddypress-bar-in-product-theme

    From here I looked within this theme directory:
    itprojecttools.com/wp-content/themes/product/library/components/buddypress

    and found that buddypress-navigation.php is loading shadow-spacer. I am using this template on a straight WP3.2.1 installation without BuddyPress. So how do I resolve this please?
    Thanks again,
    Simon.

  • DavidM
    • DEV MAN’s Mascot

    Ah, this thread was marked as being related to Business Services theme so I'd assumed you had Business Services active and was looking through the theme code for that.

    As you're using Product, it does make sense now.

    I'll have to ask one of the theme developers to have a look here as well, as I really can't see how that could occur and can't replicate that in any of my test sites.

    Just to check also, could you let us know what version of WordPress you're using in this case?

    Thanks,
    David

  • mrsimnok
    • WPMU DEV Initiate

    Hello again David,
    My last update on BuddyPress might be a bit of a red-herring: shadow-spacer is there in the header.php of the Product theme too, though it shows under a section for an IE6 specific section:

    <!--[if IE 6]>
    <style type="text/css">
    .shadow-spacer{
    background: none;
    }
    </style>
    <![endif]-->

    Just thought I'd update this in case it helps track this down.

  • DavidM
    • DEV MAN’s Mascot

    Hi mrsimnok,

    Really sorry I missed your prior responses. I'm at a bit of a loss here, this isn't something I've seen before nor heard anything else regarding except that prior thread but the issue there was the member's htaccess.

    Have you looked at any issues with your htaccess file? Likely issues there would manifest themselves when using other plugins and themes.

    For that matter, you're able to use Twenty Eleven just fine, correct?

    Another thing to check too, could you get us a bit of information on your server? Is it running Linux or Windows?

    I've tagged a few of the other guys over here in case they might have some ideas as well.

    Thanks,
    David

  • Timothy Bowers
    • Chief Pigeon

    Hi mrsimnok.

    Sorry to see your still having issues.

    To speed things up a little, would you mind if I took a look at your install?

    If so I would need (but don't post them here) your site details with admin access and FTP. I might want MySQL access at some point but probably not.

    You can get in touch through the contact form:

    https://premium.wpmudev.org/contact/

    To make things quicker please include some way we can chat (other than email) perhaps gtalk, Yahoo, MSN, Skype, heck I can even do Facebook chat
    Just address it to me. :slight_smile:

  • mrsimnok
    • WPMU DEV Initiate

    Thank you David and Timothy. I'm running on linux David, and yes I'm able to use twenty eleven with no problems. I haven't checked the .htaccess file for errors but it's a fresh install.

    Timothy, I have set up the FTP and admin user accounts for you and sent you details of them and how to reach me via the contact form.

    Thanks for your help,
    Simon.

  • DavidM
    • DEV MAN’s Mascot

    Hi Simon,

    Thanks for sending that through. Tim can have a more detailed look at the setup, being an expert with server issues, among other things, but one thing I noticed really quickly is that your Media Library images are not found.

    I suspect that has to do with file/folder permissions on your site. How did you go about installing this?

    Thanks,
    David

  • mrsimnok
    • WPMU DEV Initiate

    Hi David,

    The images were there before i started again, but I'm surprised the references to them remain. To start again I deleted all of my files from the domain including the .htaccess. I dropped all the tables in phpmyadmin then downloaded a fresh install of WP3.2.1 from the repository and did the 5 min installation. I re-used the same (I presume empty after I dropped all tables?) db as before.

    Thanks,
    Simon.

  • Philip John
    • DEV MAN’s Apprentice

    Ah well, worth a shot I suppose.

    Just been having a look myself. I tried uploading my own copy of Product but no luck. Discovered that It's the page left sidebar which is showing but couldn't figure out why.

    I think the next thing to try is a fresh database. I.e., delete all the tables from the database and go through the install script. That will get rid of the posts, pages and media you have there at the moment though so do a backup.

    Thanks

  • mrsimnok
    • WPMU DEV Initiate

    Hi Phil, thanks - there are no posts in this domain yet so a new installation is fine. However I think I should leave this for Tim to look at first, in case there's a underlying problem which he can pick up before we blast it away with a fresh install. If I don't hear back from him in a day I'll do as you suggest and delete the database and start over again.

  • Timothy Bowers
    • Chief Pigeon

    I'm just going through it now. :slight_smile:

    I won't keep updating the thread constant. But just to note, I quickly checked the path that the images refer to. Looking with Chrome Dev tools I see:

    wp-content/uploads/2011/11/pig.jpg

    But you only have the following path available:

    wp-content/uploads/2011/12/

    With not contents inside that directory.

    I've added you to gtalk, when you get a moment we could chat as well. :slight_smile:

  • Timothy Bowers
    • Chief Pigeon

    Uploading new media gives the correct path and is viewable from the front end:

    http://itprojecttools.com/?attachment_id=241

    I note your current PHP version is not the WordPress required version. WordPress has a minimum requirement of PHP version 5.2.4 or greater as you can see:

    http://wordpress.org/about/requirements/

    Your MySQL version looks fine.

    So first of all I would upgrade your version of PHP to be sure there is not an issue there.

  • Timothy Bowers
    • Chief Pigeon

    Just to update everyone here.

    Its a tough one, we didn't quiet find a resolve.

    First of all the usual was done, check for conflicts, fresh install, fresh files, etc, etc. But still something was not working.

    On our servers it all seems to work fine. So that would lead me to believe its something specific to the set up perhaps. No major errors reported either.

    So looking at the php set up I noted that SuHosin is enabled:

    http://www.hardened-php.net/suhosin/

    Here is a brief summery form their site about what this does:

    Suhosin is an advanced protection system for PHP installations. It was designed to protect servers and users from known and unknown flaws in PHP applications and the PHP core. Suhosin comes in two independent parts, that can be used separately or in combination. The first part is a small patch against the PHP core, that implements a few low-level protections against bufferoverflows or format string vulnerabilities and the second part is a powerful PHP extension that implements all the other protections.

    Before chasing other paths I thought it logical to test this one first, it could well be a red herring but still worth a try.

    I googled of course and noted various issues reported elsewhere, some close to what is happening here, some on non-WordPress systems but still similar in what is happening.

    As such, I've advised Simon to contact his provider and ask that they disable SuHosin and then test again to see if that was the issue before spending to much more time investigating further.

    In some issues I've seen it related to the use of ini_set and how SuHosin restricts it.

    If anyone else has this issue then I would advise the same, turn SuHosin off and test again to see if that is the cause of the probelm.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.