Themify builder can not edit live page

Themify builder adds an dedit page and themify builder Do you know what wpmudev plugins might disrupt themify builder from live editing a page? I have 88 plus wpmudev plugins and one or more stops the themify builder from editing and displaying some pages properly. Do you have a list of plugins that I can disable to see if the problem is solved ?

Could domain mapping, login redirect, etc be the problem?

Thank you

  • Predrag Dubajic
    • Support

    Hi wpmudevorg24,

    Hope you’re well :slight_smile:

    I must say that’s quite a lot of plugins in one place, especially if there are ones that are not from our collection installed as well.

    It doesn’t necessarily mean that the plugin is directly in conflict with the Themify builder, it could be conflict with some other plugin that throws console error and stops builder from working as well.

    I’m not aware of what plugins from our collection could actually cause this but if you could grant us support access to site in question and give us some steps needed to see this issue in action we can check console and see if there’s anything there telling us where to look.

    To enable support access you can follow this guide here:

    Best regards,


  • Lee
    • Syntax Hero

    All the plugins save 1 is a wpmudev plugins. I have been wondering there isn’t a group or collection loading ability of the wpmudev plugins. The ones activated don’t overlap that much. All the features for a multisite are in all these plugins.

    I have loaded the themify builder in a brand new no plugin wordpress install and it works fine.

    I have not debugged wordpress plugins so don’t know the first step.

    Off the top of your head any plugins to eliminate that you can think of?

    I’ll setup something for your access if I can’t pick a couple of plugins to eliminate and the problem still exists.

  • Lee
    • Syntax Hero

    Figured out what the problem is with themify builder and a multisite with “Domain mapping” plugin activated and a real domain mapped to a subsite. so test.domain.tld had a mapped domain test.tld.

    If I used test.tld in the url when directed to edit the website page it does nothing but if I switch that test.tld to the test.domain.tld url and keep the exact same url parms the edit page comes up properly.

    So is this a “Domain Mapping plugin” problem or the Themify editor problem ????

    One other thing to note:

    wp-config.php has the following:

    define(‘WP_HOME’,’https://’. $_SERVER[ ‘HTTP_HOST’ ]);

    define(‘WP_SITEURL’,’https://’. $_SERVER[ ‘HTTP_HOST’ ]);


    Thanks in advance.

    update 2:

    When I delete the domain mapping then the original url test.domain.tld is used for all links and the themify builder editor works fine.

    When I map the test.tld domain to test.domain.tld the “view” and “themify builder” links for each page listed on the wordpress Pages page are ALWAYS mapped domain while edit or quick edit points to the original test.domain.tld url. This happens regardless if I force or not force the site to use test.tld with the domain mapping settings.

  • Adam Czajczyk
    • Support Gorilla

    Hello wpmudevorg24!

    It’s good to know that you managed to identify the source of an issue. I wouldn’t however say that there’s a bug in Domain Mapping plugin that’s causing it. By default, WordPress is not yet handling domain mapping/multiple domains in native code so any solution that’s handling such a feature even though WordPress Codex-compliant is an extension.

    I believe that Themify Builder is following core WP standards and as such simply doesn’t support Domain Mapping. I think this is something that Themify Builder developers should introduce to their code as a feature. Have you already tried to get in touch with them and ask them whether they are planning any feature of this kind of if there a fix for this?

    I think it would be worth giving a shot.

    Best regards,


  • Lee
    • Syntax Hero

    I have been pinging you and themify support on this issue. I will add your comments on their support ticket.

    I have noticed something. If you go the network admin menu and click on visit site from that sub drop down you get the original url-domain or subdomain of the multisite and thus themify edits just fine. But this mapped domain is not consistent in various parts of the admin pages such as pages->somepage-> edit, quick edt, view, themify builder are different.

    I’ll drop a note here if I hear anything. thanks.

  • Adam Czajczyk
    • Support Gorilla

    Hello wpmudevorg24!

    Thank you for this additional information. I’m also keen on what they say as even in case they wouldn’t be able (or willing) to fix their scripts, they hopefully may provide us with some info that would help us.

    Let me know please when you get a response from them :slight_smile:

    Best regards,


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.