There are several cases in point. This one can be used :

There are several cases in point.
This one can be used :
This is the situation of a subfolder wp install creating a redirect which is slowing down the homepage load very very much.
I am asking here for a good advice how to annihilate this big slow down due to the subfolder redirect.
Thanks. Cif

  • Adam Czajczyk

    Hey @cif_malek,

    I hope you're well today and thank you for your question!

    From what I can see there's a one major redirect on that site: it redirects browser from http to a https secure connection. Are you referring to this one? If so, it does indeed consume quite a lot of time. Now I can only guess that you're using a plugin (probably the Wordpress HTTPS which is the most popular one) to redirect traffic from http to https. It seems like it might be the reason.

    First of all try to disable it and see if the site runs significantly faster on an unsecure plain http connection. If so, try a different approach:

    1) Go to your dashboard's "Settings" -> "General" page and make sure that both the "WordPress Addresss (URL)" and "Site Address (URL)" are prefixed with "https://" instad of "http://"
    2) Login to your site (install directory) via FTP and edit .htaccess file. Paste this code inside:

    RewriteEngine On
        RewriteCond %{HTTPS} !=on
        RewriteRule ^(.*) https://%{SERVER_NAME}/$1 [R,L]

    Remember to adjust the code to your existing .htaccess rules. For example - most likely there's already the rule "RewriteEngine On" and you don't need to double it.

    I hope that helps.


  • Adam Czajczyk

    Hello @c@cif_malek,

    I hope you're doing well and thank you for the clarification on this!

    The question is: did you manage to resolve the issue or did you just removed the item in question from the page? I'm asking because I can't find it (or am I missing something). I do understand that it's been quite a while since you posted you last post here but if you still need any assistance on this I'd like to help. Please advise.


  • Adam Czajczyk

    Hello cif_malek,

    I'm sorry for the delay here and I hope you're well today. Sure I'd like to help you, though I couldn't spot the redirection in question recently. Perhaps that's because in my browser's console there was none while I was trying to examine the issue in a more detailed way. I've cleared all the caches, compared the console output with the link you gave me and there it was.

    That said, I've got two more questions:

    1) What happens if you turn off WP Super Cache plugin that you're using (and clear all caches)? Did you try it?

    2) Can you please grant me a support access to your dashboard so I could take a closer look? To do so go to your dashboard's:

    "WPMU DEV" -> "Support" page -> "Support" tab

    and click on "Grant access".

    Please be sure to make a full backup copy of your site first.

    Let me know if I can access your site.


  • cif_malek

    Did you view the given link :!/ex2hxK/ ?
    If not can you view it ?
    If yes then on that page now displaying in front you can you see the tab : waterfall ?
    Then under do you see the header : File/path ?
    Then after that can you see below it : the 2nd line ?
    THERE !
    You see a redirect because the wp install is on subfolder of the main doamain and that looses time on the loading of the home page. That is my issue in case you have an idea how to solve it.

  • Adam Czajczyk

    Hey @cif_malek,

    I hope you're well today!

    I've cleared all the caches, compared the console output with the link you gave me and there it was.

    I did find the redirection finally, that's why I've asked you those questions in my recent post :slight_smile: I'm sorry if I didn't make it clear enough.

    That being said:

    1) What happens if you disable the WP Super Cache plugin and clear all the caches? Have you tried it? Please advise!


    wp install is on subfolder of the main doamain and that looses time on the loading of the home page.

    How is this redirection done? Directly with .htaccess or any other way?

    Let me know please!


  • cif_malek

    Hello again and thank you.
    The problem existed before supercache.
    I am not (not) doing any redirect whatsoever.
    It is just there installed.
    Then when doing the usual speed test I found out about that situation shown in the waterfall of pingdom. And since then wondered how I could fix it.
    Here is the htacess file

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /showcase/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /showcase/index.php [L]

    # END WordPress

    I never edited that so give it to you as I got it.
    Thanks again for your help.

  • Adam Czajczyk

    Hello cif_malek,

    I hope you're well today. I'm sorry for another delay on my side.

    I've run some more test on your site and the conclusion is that it is possible that there's a DNS issue. I've setup a test site on my own server with a domain that's directly pointing to this server and I've installed WordPress in a subfolder, as yours is. There's no redirection at all and although I've tried different settings and some additional plugins, I wasn't able to force any redirection to appear.

    Having said that, might there be any redirection at the DNS level? I've noticed that your domain is set to redirect to Google Plus. How is this redirection made: is it made with .htaccess located in a root folder for the domain (if so, could you please post its content?) or other way?

    I know I'm asking more questions than giving answers but that's the only way I can track down the problem.


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.