register & register 2

Hi there,
By default, I had the page /register/ setup by WP
The membership plugin created and using a /register-2/

Those are 2 different pages, 2 different process
The default register is using 2 columns, with fields created by BuddyPress
The register 2 is going to the membership groups I've created

Since the plugin is using /register-2/ ...
I have deleted the /register/ in order to rename the /register-2/ into /register/
But once that done : I'm now being redirected to the default page
*which I don't want to use

I have re-created a /register/ with no content on it but it changes nothing

Question is : Where is the "Membership2 Pro" register page now ?

Thanks

  • Adam Czajczyk

    Hey Steven,

    I hope you're well today and thank you for your question!

    Do you wish to use Membership 2 Pro register page or your previous (BuddyPress) register page?

    Here are possible scenarios for this:

    1. Use Membership 2 Pro page:

    - remove /register/ page
    - change /register-2 page slug to /register
    - to to "Membership 2" -> "Settings" page -> "General" tab and make sure that this page is selected as a "Membership Register" page.

    2. Use existing (BuddyPress) registration page:

    - add this line to your wp-config.php file:

    add_filter('ms_frontend_handle_registration', '__return_false');

    - make sure that "Membership 2" -> "Settings" page -> "General" tab -> "Register" option points to the page of choice (this is optional as we've just deactivated Membership 2 Pro registration process but will not do any harm).

    I hope that helps. In case you need further assistance, please let me know and I'll be glad to help!

    Cheers,
    Adam

  • Steven

    Hi Adam,
    As I said, I want to use the membership pro register page
    I did what you described above and that's how I lost the page in the process !
    Everything points to the buddy press page now
    *which is the problem I'm trying to fix

    "Membership 2" -> "Settings" page -> "General"
    The /register-2/ is selected but it goes to /register/

    All was fine before i deleted the /register/
    *looks like that action create the problem

    What am I suppose to do now ?
    Thanks