there! I was not able to solve by myself an issue with

Hello there!

I was not able to solve by myself an issue with Custom sidebar Pro. This is how our sidebar looks normally: http://krisstelljes.staging.wpengine.com/selbstmotivation-lernen/ (looks like this on my Mac: http://screencast.com/t/ee13ywqevpU)

And this is how the Custom Sidebar looks with the very same widgets inside: http://krisstelljes.staging.wpengine.com/facebook-anzeigen/ (looks like this on my Mac: http://screencast.com/t/cTfSvkKYWD)

So it looks kind of broken and display not correctly, although it has the same elements in it (for testing).

Can anyone help me to find a way to make it work?

  • Julius

    Hello! Thank you for your help.

    I attached also the screenshots (by the way - the Screencast Links I posted work for me if I copy/paste them in the browser, but they dont work if I just click them... strange...). You see the differences: for example the banner images doesn't have a border, the Facebook Script will not appear, ect...

    I "rebuilded" the normal sidebar as a custom sidebar (since the custom sidebar will only have little differences from normal sidebar) so its possible that elements have other IDs I guess. Since its a staging area, I mention that the "normal" sidebar" is the original copy that is on the live install also, while the custom sidebar I rebuild on the staging area - if that might have to do with it...

    I also granted access to the site if needed.

    Thank you very very much for the support!

  • Predrag Dubajic

    Hey @Julius,

    The links from images are also adding brackets to it and that is why it doesn't show :slight_smile:

    Thanks for granting access, I believe I have found a solution .
    When you go to your widgets are and expand your new sidebar you can Edit it and then enable Advanced - Edit custom wrapper code for that widget area.
    Now I looked at your HTML structure and added this code in Before Widget field:
    <section id="%1$s"><div class="awr scn">
    And this in After Widget field:
    </div></section>
    Saved the changes and it should be showing as your other sidebar now.

    Let me know if all is working as expected.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.