Problems with padding time

Hi there,

I'm aware that many questions about this problem were asked and answered, but so far I have found no acceptable solution for my case, so please allow me to ask once more.

I have a 40-min service, and after each appointment I need a 20-min break. The appointment must start at EXACTLY 9:00, 10:00, 11:00, ... 17:00 and ends at 9:40, 10:40... Also displayed on front-end is a weekly schedule, not monthly.

My current settings:
- Padding add-on OFF
- Durations add-on ON
- Service duration: 60 mins
- Time base: 60 mins
- Using the bespoke code to modify service duration displayed on front-end as 40 mins.

The problems:
- The time slot on schedule table is showed as 9:00 - 10:00, 10:00 - 11:00 and so on. I want it to be 9:00 - 9:40, 10:00 - 10:40.
- On customer's GCal, the service takes up 60 mins, which is undesirable. It should be 40 mins.

Please suggest me the way to fix this. And I really hope a professional Padding option would be included in a future update of A+. Thank you